FluxBB.fr

Le site des utilisateurs francophones de FluxBB.

Recherche rapide

Vous n'êtes pas identifié(e).

Version 1.4.13 : [.tar.gz][.zip] (maj 20/10/2014)
Pack langue française pour 1.4.x : [.zip] (maj 06/01/2012)

Branche 1.5.x : fluxbb.org
Pack langue française pour 1.5.x : [.zip] (maj 14/01/2016)

Ancienne Version 1.2.24 fr : [.zip] (maj 26/08/2011)

Vous avez un problème ?
Avant de poser votre question sur les forums d'entraide nous vous invitons à consulter :

#1 12-08-2010 10:32:05

adaur
Habitué très actif
Lieu : Derrière Notepad ++ !
Inscription : 25-09-2008
Messages : 1 937
Site Web

Rendre compatibles des thèmes FluxBB/PunBB 1.2.* avec FluxBB 1.4

Cette astuce est sûrement indispensable!

Au bout de quelques étapes, tous les styles de FluxBB/PunBB 1.2 marcheront avec la 1.4:

1/ Télécharger l'archive style_1.2_to_1.4.zip ici ou miroir.
2/ Extraire le contenu de /imports dans le /imports de /style.
3/ Dans /style, créer un nouveau dossier ayant pour nom celui de votre style.
4/ Dans ce dossier, extraire le contenu du dossier /templates
5/ Extraire le contenu de l'archive contenant le style à la racine de votre installation FluxBB.
6/ Ça marche!

Exemple: PunBB 1.2 CrystalBlue sur FluxBB 1.4.2

crystalblue2.png

Technique publiée par daris.

Dernière modification par adaur (15-10-2012 16:27:41)


"As code is more often read than written it's really important to write clean code." - Franz
Twitter: @adaurfr
Mon fork de FluxBB: FeatherBB

Hors ligne

#2 24-08-2010 02:14:57

Pame
Habitué
Inscription : 23-03-2009
Messages : 109

Re : Rendre compatibles des thèmes FluxBB/PunBB 1.2.* avec FluxBB 1.4

Intéressant wink Merci

PS: plus généralement on peut alors copier les fichiers de /include/template/ dans /style/Mon-Style-A-Moi/ et c'est eux qui deviennent prioritaires ?

Hors ligne

#3 24-08-2010 10:16:22

adaur
Habitué très actif
Lieu : Derrière Notepad ++ !
Inscription : 25-09-2008
Messages : 1 937
Site Web

Re : Rendre compatibles des thèmes FluxBB/PunBB 1.2.* avec FluxBB 1.4

PS: plus généralement on peut alors copier les fichiers de /include/template/ dans /style/Mon-Style-A-Moi/ et c'est eux qui deviennent prioritaires ?

ça je ne saurais pas te dire, je n'ai pas vérifié si les tpl utilisés sont ceux de la 1.2 ou 1.4...


"As code is more often read than written it's really important to write clean code." - Franz
Twitter: @adaurfr
Mon fork de FluxBB: FeatherBB

Hors ligne

#4 21-11-2010 15:22:08

Ptii-GunZ
Nouveau Membre
Lieu : France
Inscription : 21-11-2010
Messages : 3
Site Web

Re : Rendre compatibles des thèmes FluxBB/PunBB 1.2.* avec FluxBB 1.4

Moi sa marche pas sad

Hors ligne

#5 21-11-2010 15:59:54

adaur
Habitué très actif
Lieu : Derrière Notepad ++ !
Inscription : 25-09-2008
Messages : 1 937
Site Web

Re : Rendre compatibles des thèmes FluxBB/PunBB 1.2.* avec FluxBB 1.4

Avec si peu d'éléments, je ne peux pas vraiment t'aider... Première chose, vérifie bien que l'arborescence est bien respectée, et quand tu lances le style depuis ton profil, qu'est-il affiché?


"As code is more often read than written it's really important to write clean code." - Franz
Twitter: @adaurfr
Mon fork de FluxBB: FeatherBB

Hors ligne

#6 01-12-2010 15:16:19

philodido
Nouveau Membre
Inscription : 01-12-2010
Messages : 5

Re : Rendre compatibles des thèmes FluxBB/PunBB 1.2.* avec FluxBB 1.4

Salut je suppose que le style VBStyle-red fait parti des styles version 1.2 parce que j'ai quelque soucis à l'intégré. Mais si j'ai bien compris avec ton astuce ça devrait mieux fonctionner ? c'est bien ça ?

En tout cas merci pour le post.

Hors ligne

#7 01-12-2010 15:20:44

adaur
Habitué très actif
Lieu : Derrière Notepad ++ !
Inscription : 25-09-2008
Messages : 1 937
Site Web

Re : Rendre compatibles des thèmes FluxBB/PunBB 1.2.* avec FluxBB 1.4

Oui, normalement il devrait bien ressortir wink.


"As code is more often read than written it's really important to write clean code." - Franz
Twitter: @adaurfr
Mon fork de FluxBB: FeatherBB

Hors ligne

#8 01-12-2010 15:29:29

philodido
Nouveau Membre
Inscription : 01-12-2010
Messages : 5

Re : Rendre compatibles des thèmes FluxBB/PunBB 1.2.* avec FluxBB 1.4

ok je vais tenter smile Merci de ta réponse ultra rapide

Hors ligne

#9 01-12-2010 15:59:01

philodido
Nouveau Membre
Inscription : 01-12-2010
Messages : 5

Re : Rendre compatibles des thèmes FluxBB/PunBB 1.2.* avec FluxBB 1.4

J'ai suivi suivi la procedure à la lettre mais ça ne marche pas , le style n'apparait même pas dans les propositions au niveau de l'interface d'admin.

Hors ligne

#10 01-12-2010 16:21:37

philodido
Nouveau Membre
Inscription : 01-12-2010
Messages : 5

Re : Rendre compatibles des thèmes FluxBB/PunBB 1.2.* avec FluxBB 1.4

Je voulais essayer de retrouver l'archive CrystalBlue pour voir si il y avait une différence avec vbstyle-red mais impossible de la trouver.

Hors ligne

#11 06-12-2010 00:36:30

Salsa2001
Membre
Inscription : 26-11-2009
Messages : 42

Re : Rendre compatibles des thèmes FluxBB/PunBB 1.2.* avec FluxBB 1.4

ça a très bien marché pour moi smile Je suis sous Fluxbb 1.4.2 avec le thème SexyBlack smile Merci de l'astuce big_smile

Hors ligne

#12 26-01-2011 21:20:59

Dragon Imperator
Régulier
Lieu : Sur le Web 2.0
Inscription : 16-10-2010
Messages : 84
Site Web

Re : Rendre compatibles des thèmes FluxBB/PunBB 1.2.* avec FluxBB 1.4

Ca marche super bien ! Merci smile

Juste quelques retouches a faire car parfois les proportions sont un peut perdu

Version de mon forum : 1.4.2

Dernière modification par Dragon Imperator (26-01-2011 21:30:39)

Hors ligne

#13 09-04-2011 11:18:53

astahxo
Membre
Inscription : 03-04-2011
Messages : 20

Re : Rendre compatibles des thèmes FluxBB/PunBB 1.2.* avec FluxBB 1.4

Même problème que philodido,
Le style ne s'affiche même pas dans les propositions (sxs v2 sous fluxbb 1.4.5)
Edit: A la racine du forum, j'avais recrée un dossier au lieu d'extraire directement le contenu. A part quelques modifications à apporter, tout marche très bien!

Dernière modification par astahxo (09-04-2011 11:37:45)

Hors ligne

#14 21-06-2011 13:53:13

a-snowboard
Habitué très actif
Inscription : 20-06-2011
Messages : 440
Site Web

Re : Rendre compatibles des thèmes FluxBB/PunBB 1.2.* avec FluxBB 1.4

Pour infos les liens sont mort et j'ai pas réussi la manip.

J'ai pris le thème Kontrast

j'ai mis le template dans style, Mais j'ai pas de dossier template. Donc j'ai bidouillé comme j'ai pu

le contenu de import dans le /import du FTP

j'ai créé un dossier kontrast ou j'ai mis les images dedans.

De ce fait dans l'administration j'ai le choix. J'ai activé ça marche.

Mais alors une incompatibilité de tonnerre !

Je vous met le fofo avec ce thème pour vous en rendre compte ? (de tout manière il est pas "ouvert") ou ça ira ?


Le roi du snowboard ! Sans prétention hein ? lol

Fluxbb 1.4.7, Forum Photo Paris

Hors ligne

#15 21-06-2011 13:55:40

a-snowboard
Habitué très actif
Inscription : 20-06-2011
Messages : 440
Site Web

Re : Rendre compatibles des thèmes FluxBB/PunBB 1.2.* avec FluxBB 1.4

a oui j'ai compris, le contenu du template est dans le dossier à télécharger en début de topic ?

vu que les liens ne marchent pas je ne peux pas vérifier !


Le roi du snowboard ! Sans prétention hein ? lol

Fluxbb 1.4.7, Forum Photo Paris

Hors ligne

#16 21-06-2011 14:26:11

a-snowboard
Habitué très actif
Inscription : 20-06-2011
Messages : 440
Site Web

Re : Rendre compatibles des thèmes FluxBB/PunBB 1.2.* avec FluxBB 1.4

Bah c'est bon ! Max m'a aidé via le chat ! J'ai du déposer 4 dossier a 4 endroit différent !

Bonne soirée !


Le roi du snowboard ! Sans prétention hein ? lol

Fluxbb 1.4.7, Forum Photo Paris

Hors ligne

#17 21-06-2011 16:02:03

WinuX
Habitué actif
Inscription : 17-07-2010
Messages : 390

Re : Rendre compatibles des thèmes FluxBB/PunBB 1.2.* avec FluxBB 1.4

Les liens ne sont pas mort wink

Hors ligne

#18 21-06-2011 16:25:30

a-snowboard
Habitué très actif
Inscription : 20-06-2011
Messages : 440
Site Web

Re : Rendre compatibles des thèmes FluxBB/PunBB 1.2.* avec FluxBB 1.4

bah tout à l'heure ça ne marchait pas...

Désolé !


Le roi du snowboard ! Sans prétention hein ? lol

Fluxbb 1.4.7, Forum Photo Paris

Hors ligne

#19 09-07-2011 08:15:58

Mickael
Membre
Inscription : 09-04-2011
Messages : 16
Site Web

Re : Rendre compatibles des thèmes FluxBB/PunBB 1.2.* avec FluxBB 1.4

Fonctionnel, merci beaucoup! smile

Hors ligne

#20 20-08-2011 22:36:50

HellsAngels
Membre
Inscription : 06-03-2010
Messages : 44

Re : Rendre compatibles des thèmes FluxBB/PunBB 1.2.* avec FluxBB 1.4

J'ai une question qui me turlupine est-ce que apres la manipulation effectué les theme 1.4 serons toujours compatible???

Hors ligne

#21 21-08-2011 14:52:31

adaur
Habitué très actif
Lieu : Derrière Notepad ++ !
Inscription : 25-09-2008
Messages : 1 937
Site Web

Re : Rendre compatibles des thèmes FluxBB/PunBB 1.2.* avec FluxBB 1.4

Oui, aucun souci de ce côté là.


"As code is more often read than written it's really important to write clean code." - Franz
Twitter: @adaurfr
Mon fork de FluxBB: FeatherBB

Hors ligne

#22 21-08-2011 21:12:19

HellsAngels
Membre
Inscription : 06-03-2010
Messages : 44

Re : Rendre compatibles des thèmes FluxBB/PunBB 1.2.* avec FluxBB 1.4

Ok merci de ta reponse

Hors ligne

#23 15-12-2011 18:12:48

Lorenzo
Nouveau Membre
Inscription : 10-12-2011
Messages : 3

Re : Rendre compatibles des thèmes FluxBB/PunBB 1.2.* avec FluxBB 1.4

Bonjour,
Les liens pour télécharger l'archive style_1.2_to_1.4.zip semblent morts.
Pourriez-vous m'indiquer un lien valide ?
Merci d'avance

Hors ligne

#24 15-12-2011 19:58:32

Spiky
Habitué très actif
Inscription : 10-04-2008
Messages : 829

Re : Rendre compatibles des thèmes FluxBB/PunBB 1.2.* avec FluxBB 1.4

Bonsoir,
Les liens sont effectivement HS, je te le poste : ICI
Mais je doute qu'il soit toujours d'actualité car depuis août 2010 il y a des changements des les css.
Il serait plus opportun de partir sur un style 1.4.x et de le modifier à ta convenance.

Dernière modification par Spiky (15-12-2011 20:20:01)


I don't play against a team in particular. I play to fight against the idea to lose... Life is beautiful.
Quelque #ID et beaucoup de .CLASS

Hors ligne

#25 06-01-2012 15:33:41

adaur
Habitué très actif
Lieu : Derrière Notepad ++ !
Inscription : 25-09-2008
Messages : 1 937
Site Web

Re : Rendre compatibles des thèmes FluxBB/PunBB 1.2.* avec FluxBB 1.4

Liens màj, fluxbb PL a en effet changé d'extension.


"As code is more often read than written it's really important to write clean code." - Franz
Twitter: @adaurfr
Mon fork de FluxBB: FeatherBB

Hors ligne

Pied de page des forums