FluxBB.fr

Le site des utilisateurs francophones de FluxBB.

Recherche rapide

Vous n'êtes pas identifié(e).

Version 1.4.13 : [.tar.gz][.zip] (maj 20/10/2014)
Pack langue française pour 1.4.x : [.zip] (maj 06/01/2012)

Branche 1.5.x : fluxbb.org
Pack langue française pour 1.5.x : [.zip] (maj 14/01/2016)

Ancienne Version 1.2.24 fr : [.zip] (maj 26/08/2011)

Vous avez un problème ?
Avant de poser votre question sur les forums d'entraide nous vous invitons à consulter :

#1 20-01-2017 14:25:46

Olivier2B
Habitué actif
Inscription : 21-10-2006
Messages : 397
Site Web

Rester en 1.2 ou évoluer ???

Bonjour à tous,

Pour faire court avant mes 2 questions, j'ai commencé il y 10 ans a créer un forum avec Fluxx (il me semble que c'était PunBB à l'époque) et mon forum tourne actuellement sous FluxBB 1.2.24.

J'ai, il y a quelques semaines installer la dernière version 1.5 en interne (en me rendant compte, trop tard que cette version 1.5 par rapport à la 1.4 n'était pas apprécier par les administrateurs du forum Français). Mais ma question reste la même, quel que soit la version 1.4 ou 1.5 ....

Est il possible en fin de compte de rester avec ma 1.2 ? ...... qui tourne tranquillement mais surement où j'avais effectuer à l'époque toutes les modifications nécessaires, une trentaine entre les mods et les astuces (j'ai seulement usermap qui n'affiche plus la carte, sinon tout le reste fonctionne) et où j'avais obtenu de l'aide sur le forum car a cette époque, la communauté PunBB ou FluxBB était bien plus importante et j'ai l'impression au vu des difficultés rencontrés pour trouver des renseignements, peut être aussi car j'ai installer à tort sans savoir la 1.5.10 que de passer en 1.4 ou 1.5 est téméraire. ...

Première question : Donc faut il évoluer vers FluxBB 1.4 ou 1.5 pour attendre la 2.0 si j'ai bien compris ... ou rester en 1.2 avec toutes mes modifications qui tournent tranquillement ... ou chercher vers quel autre scripte de forum évolué ?

Je préfère si cela était possible rester ici car cela fait 10 ans que je tourne sur FluxBB et même si je suis complétement nul en PHP ou autres langages bizarre, j'ai toujours réussi à m'en sortir grâce à l'aide de ce forum et aux réponses portées mais çà, c'était il y a 10 ans ..... d’où ma question smile

Deuxième petite question : je suis passé de la 1.2 à la 1.5 (sans installer les mod car là c'est un peu plus compliqué) très facilement avec une base de donner de 500 Mo pensez vous que dans l'avenir si la 2.0 sort, se sera aussi possible de passer de la 1.2 à la 2.0 ?

Voilà, j'espère avoir été court ... merci et bonne fin de semaine

Olivier

Hors ligne

#2 20-01-2017 14:41:44

Otomatic
Régisseur
Lieu : Paris, France
Inscription : 12-12-2005
Messages : 3 475
Site Web

Re : Rester en 1.2 ou évoluer ???

Bonjour,

La 2.0.... est, quelque peu l'Arlésienne et même si elle sort un jour, je ne sais pas si j'y passerais, d'autant plus qu'utiliser un framework n'est pas mon truc. Je préfère rester avec PHP et MySQL (Ou mariaDB) basiques.
La branche 1.5 est bien, avec quelques mod*si nécessaire. Le passage 1.2 -> 1.5 peut se faire tranquillement en local. Changer de forum est possible, mais si FluxBB 1.2 ou 1.5 convient aux besoins, pourquoi changer.

... cette version 1.5 par rapport à la 1.4 n'était pas apprécier par les administrateurs du forum...

L'admin en chef, mais par procrastination et rébellion - en fin de compte, il n'a rien vraiment contre.

*Les mods que j'utilise pour mon propre forum sont celles qui peuvent être installées automatiquement avec Mod Installer.


Ce n'est pas parce que l'erreur se propage qu'elle devient vérité. Gandhi
Sont différents : ça et sa - est et ait - à et a - ce et se - mes et mais ou met - été et était - c'est et ces - ce-si et ceci
La vie sans musique est tout simplement une erreur, une fatigue, un exil. Friedrich Nietzsche

Hors ligne

#3 21-01-2017 18:40:19

Olivier2B
Habitué actif
Inscription : 21-10-2006
Messages : 397
Site Web

Re : Rester en 1.2 ou évoluer ???

Bonsoir,

Merci Otomatic pour tes explications. En faite, mon inquiétude de rester sur la 1.2 c'est pour une chose que j'ai vu à droite et à gauche sur les forums qui parlent des différents CSM pour la création d'un forum, c'est leur fonctionnement  dans le temps par rapports à son hébergeur et a sa version PHP.

Je suis actuellement chez Celeonet depuis 13 ans et la version PHP indiqué est 5.2/5.3 / Version SQL MySQL 5.1.41 donc d'après toi comment un Fluxbb 1.2.23 va t'il réagir le jour ou mon hébergeur va évoluer. Car je crois que certains hébergeur sont déjà avec des versions au dessus. Ni connaissant rien en programmation, quel que soit le langage, je me pose des questions et m'inquiètes.

Si toi ou des personnes peuvent me renseigner car c'est vrai aussi que je vois plus beaucoup de forum sous 1.2 ....

Voilà mon inquiétude première

bon dimanche

Olivier

Hors ligne

#4 21-01-2017 18:45:17

Olivier2B
Habitué actif
Inscription : 21-10-2006
Messages : 397
Site Web

Re : Rester en 1.2 ou évoluer ???

Je viens juste de voir ceci, en cherchant des réponses sur la version 1.5, je suis tomber sur les explications de la 1.2 :

un serveur web (de préférence Apache).
    PHP 4.1.0 ou supérieur (PHP 5 inclus).
    MySQL 3.23.17 ou supérieur, PostgreSQL 7.0 ou supérieur ou SQLite. (voir les détails ci-dessous).

PostgreSQL: FluxBB 1.2.* a été entièrement testé sur différentes version comprises entre la 7.3.3 et la 7.4.5, mais il devrait fonctionner correctement avec toutes les versions supérieurs à la 7.0. Merci de noter qu'il vous faut PHP 4.3.0 ou supérieur pour le support de PostgreSQL.

SQLite: FluxBB 1.2.* a également été entièrement testé sur les versions 2.8.11 et 2.8.14 de SQLite, mais devrait fonctionner avec toutes versions.

Donc logiquement, devrais je avoir des PROBLÈME si mon hébergeur évolue ??? PHP 6 ou 7 ... etc ???

REbon dimanche

Dernière modification par Olivier2B (21-01-2017 18:54:43)

Hors ligne

#5 22-01-2017 09:51:24

Otomatic
Régisseur
Lieu : Paris, France
Inscription : 12-12-2005
Messages : 3 475
Site Web

Re : Rester en 1.2 ou évoluer ???

Bonjour,

Les versions indiquées par Celeonet PHP 5.2/5.3 et MySQL 5.1.41 sont totalement obsolètes.
Avec des versions récentes de PHP ou MySQL, FluxBB 1.2, va, à coup sûr, poser des problèmes.

FluxBB 1.5.10 fonctionne sans aucun problème avec PHP de 5.4.0 à 7.1.1 en passant par 5.5 et 5.6, MySQL 5.5, 5.6 et 5.7 ainsi que MariaDB 5.5 et 10.1.


Ce n'est pas parce que l'erreur se propage qu'elle devient vérité. Gandhi
Sont différents : ça et sa - est et ait - à et a - ce et se - mes et mais ou met - été et était - c'est et ces - ce-si et ceci
La vie sans musique est tout simplement une erreur, une fatigue, un exil. Friedrich Nietzsche

Hors ligne

#6 22-01-2017 11:45:22

Olivier2B
Habitué actif
Inscription : 21-10-2006
Messages : 397
Site Web

Re : Rester en 1.2 ou évoluer ???

Bonjour Otomatic,

merci pour ta réponse. Je fais bien de tranquillement passer en 1.5  smile

J'ai une question par rapport à la migration d'un forum 1.2 à 1.5 mais je vais ouvrir un nouveau post pour ne pas polluer celui si

en tous cas merci

A bientôt, c'est sûr smile

Hors ligne

Pied de page des forums