FluxBB.fr

Le site des utilisateurs francophones de FluxBB.

Recherche rapide

Vous n'êtes pas identifié(e).

Version 1.4.13 : [.tar.gz][.zip] (maj 20/10/2014)
Pack langue française pour 1.4.x : [.zip] (maj 06/01/2012)

Branche 1.5.x : fluxbb.org
Pack langue française pour 1.5.x : [.zip] (maj 14/01/2016)

Ancienne Version 1.2.24 fr : [.zip] (maj 26/08/2011)

Vous avez un problème ?
Avant de poser votre question sur les forums d'entraide nous vous invitons à consulter :

#26 07-07-2011 20:02:39

thib3113
Habitué très actif
Lieu : Toulouse
Inscription : 11-03-2011
Messages : 542
Site Web

Re : Remarques sur la validation W3C

tu as un problème au niveau de l'encodage de ton fichier, regarde si tu est bien encodé en UTF-8(sans bom) ,

ou donne nous les lignes aux alentours de la ligne 527 , (en faisant le test de chez moi, il me dit ligne 528)

Hors ligne

#27 08-07-2011 08:51:01

Otomatic
Régisseur
Lieu : Paris, France
Inscription : 12-12-2005
Messages : 3 475
Site Web

Re : Remarques sur la validation W3C

Bonjour,

The error was: utf8 "\xE9" does not map to Unicode

Il s'agit d'un "é" iso-8859-1.


Ce n'est pas parce que l'erreur se propage qu'elle devient vérité. Gandhi
Sont différents : ça et sa - est et ait - à et a - ce et se - mes et mais ou met - été et était - c'est et ces - ce-si et ceci
La vie sans musique est tout simplement une erreur, une fatigue, un exil. Friedrich Nietzsche

Hors ligne

#28 08-07-2011 10:09:53

max2610
Habitué actif
Lieu : Bretagne
Inscription : 07-11-2010
Messages : 272
Site Web

Re : Remarques sur la validation W3C

Bonjour,

ou donne nous les lignes aux alentours de la ligne 527 , (en faisant le test de chez moi, il me dit ligne 528)

Quel est le fichier en question ?
Merci pour votre réponse.

Hors ligne

#29 08-07-2011 10:25:13

Guims
Habitué très actif
Lieu : Chez GoOgle
Inscription : 07-03-2009
Messages : 891
Site Web

Re : Remarques sur la validation W3C

Comment pourrait-on te dire de quel fichier il s'agit ? happy
A toi de regarder cela via filezilla fichier par fichier pour voir lequel/lesquels sont codé iso-8859-1 et de le modifier comme dit plus haut.

Hors ligne

#30 08-07-2011 10:53:52

Otomatic
Régisseur
Lieu : Paris, France
Inscription : 12-12-2005
Messages : 3 475
Site Web

Re : Remarques sur la validation W3C

max2610 a écrit :

Quel est le fichier en question ?

Il faudrait déjà essayer sans les pubs.


Ce n'est pas parce que l'erreur se propage qu'elle devient vérité. Gandhi
Sont différents : ça et sa - est et ait - à et a - ce et se - mes et mais ou met - été et était - c'est et ces - ce-si et ceci
La vie sans musique est tout simplement une erreur, une fatigue, un exil. Friedrich Nietzsche

Hors ligne

#31 08-07-2011 11:05:42

Guims
Habitué très actif
Lieu : Chez GoOgle
Inscription : 07-03-2009
Messages : 891
Site Web

Re : Remarques sur la validation W3C

Les pubs pour ma part ne provoquaient pas d'erreurs d'encodage ... par contre je n'ai jamais réussi à les faire passées par la validation huh

Dernière modification par Guims (08-07-2011 11:07:08)

Hors ligne

#32 08-07-2011 15:12:35

max2610
Habitué actif
Lieu : Bretagne
Inscription : 07-11-2010
Messages : 272
Site Web

Re : Remarques sur la validation W3C

Merci pour votre aide, malheureusement les pubs produisent beaucoup d'erreurs sad.

Hors ligne

#33 09-07-2011 06:06:19

Retraité
Régulier
Inscription : 22-08-2010
Messages : 82

Re : Remarques sur la validation W3C

Bonjour

J'ai connu le même soucis il y a quelques temps que toi !

Il me semble que tu as installé la Mod en ligne aujourd'hui

Le fichier en cause et le fichier langue on_line today (english)

codé en ANSI

'Last visit'            => 'dernière visite le  %s: %s'


Codé en UTF8 (sans boum)

'Last visit'            => 'dernixE8re visite le  %s: %s'

Et ça boum ! Ce qui donne raison une fois de plus  a Otomatic c'est le caractère "è"

J'ai trouvé assez vite parce que je prends soin de valider après chaque installation de mod

Dernière modification par Retraité (09-07-2011 06:06:57)

Hors ligne

#34 10-07-2011 10:43:02

mexandre
Régulier
Inscription : 20-02-2011
Messages : 67

Re : Remarques sur la validation W3C

Guims a écrit :

Les pubs pour ma part ne provoquaient pas d'erreurs d'encodage ... par contre je n'ai jamais réussi à les faire passées par la validation huh

Généralement le problème d'encodage des pubs vient des balises <script> qui utilisent l'ancien encodage avec language au lieu de type, ça tu peux le changer.

Tu peux aussi réencoder les caractères spéciaux pour que ça passe (& notamment).

Hors ligne

#35 20-08-2011 23:59:31

Llanis
Habitué actif
Lieu : Paris*75
Inscription : 26-10-2005
Messages : 333

Re : Remarques sur la validation W3C

Hop là, je reviens actif sur FluxBB après quelques longs mois d'absence.
Avec une question de fond ?

Le respect des normes W3C, c'est bien, dans une optique logique c'est encore mieux.
Quel est le véritable intérêt de suivre forum sous normage xhtml strict  ? le transitionnel est bien aussi wink

(nota : je suis intégrateur web, et je travaille sous les deux normages, je pose donc ici une simple question et ne viens pas poser un pavé dans la marre happy)


"La vie est un long fleuve tumultueux et tortueux"

Hors ligne

#36 28-09-2011 15:58:56

thib3113
Habitué très actif
Lieu : Toulouse
Inscription : 11-03-2011
Messages : 542
Site Web

Re : Remarques sur la validation W3C

bonjour, j'ai un léger problème, je cherche l'équivalent de word-wrap : break-word en CSS2.1 car en effet, la validation W3C refuse cette fonction meme avec CSS 3 ...

Hors ligne

#37 31-10-2011 21:02:47

Anthrax
Habitué
Lieu : Dans Mon Noyau Linux !
Inscription : 15-09-2011
Messages : 100

Re : Remarques sur la validation W3C

Bonsoir,

Je suis en train de valider mon forum avec l'aide précieuse de thib3113 (plus que 2 erreurs tongue) wink, mais il y a un souci que je n'arrive pas à résoudre.

Le validateur me retourne cette erreur :

capturedj.th.png

A savoir que j'ai rajouté ce bouton " Chatbox " depuis le Panel Admin, ma ligne étant la suivante :

4=<a href="http://tux-net.legtux.org/forum/chat/"target="_blank">ChatBox</a>

J'ai bien le " _ " devant " blank " et je ne vois pas d'ou pourrais venir le soucis, si jamais vous avez une idée ... Merci d'avance smile

Dernière modification par Anthrax (31-10-2011 21:04:14)

Hors ligne

#38 31-10-2011 21:12:25

Mpok
Néo Admin
Inscription : 10-08-2006
Messages : 2 917
Site Web

Re : Remarques sur la validation W3C

C'est parce que tu n'as pas le droit d'utiliser l'attribut 'target' en XHTML 1.0.
Donc il faut virer ce "target=_blank".
Et l'erreur disparaît.
(et ensuite le remplacer éventuellement par du javascript, si tu veux absolument conserver la fonctionnalité d'ouverture dans une nouvelle fenêtre).


Life is a struggle, programming is a suffer.

Hors ligne

#39 31-10-2011 21:15:03

Anthrax
Habitué
Lieu : Dans Mon Noyau Linux !
Inscription : 15-09-2011
Messages : 100

Re : Remarques sur la validation W3C

Ah, effectivement.

Je ne savais pas, merci bien smile

Pour ce qui est du JavaScript, je chercherais comment faire, une fois que je maîtriserais le PHP smile

Merci pour cette réponse rapide Mpok.

Hors ligne

#40 01-11-2011 09:48:18

Cr@sh_
Régulier
Inscription : 02-09-2011
Messages : 85
Site Web

Re : Remarques sur la validation W3C

Remplace:

target="_blank"

Par:

onclick="window.open(this.href,'_blank');return false;"

Ne marchera pas si le visiteur a désactivé le javascript mais valide xhtml strict 1.0 wink


Administrateur et fondateur de Geek-Community

Hors ligne

#41 01-11-2011 10:01:33

Anthrax
Habitué
Lieu : Dans Mon Noyau Linux !
Inscription : 15-09-2011
Messages : 100

Re : Remarques sur la validation W3C

Ah d'accord, merci Cr@sh_, je vais tester smile

Hors ligne

Pied de page des forums