Archives FluxBB.fr

Les archives de FluxBB.fr

Recherche rapide

Vous n'êtes pas identifié(e).

Version 1.4.13 : [.tar.gz][.zip] (maj 20/10/2014)
Pack langue française pour 1.4.x : [.zip] (maj 06/01/2012)

Branche 1.5.x : fluxbb.org

Version 1.2.24 fr (entièrement en français) : [.zip] (maj 26/08/2011)
Pack langue française pour 1.2.x : [.zip] [.rar] (maj 15/10/2006)

Vous avez un problème ?
Avant de poser votre question sur les forums d'entraide nous vous invitons à consulter :

#1 18-12-2009 15:21:06

Ewaa
Membre

Problème après changement d'URL.

Bonjour,
J'ai installé le PunBB en parallèle à mon site.
J'ai mis une Url banalisée, pour y travailler discrètement, le temps de le remplir et le modifier.
Ensuite, j'ai voulu changer l'Url, la mettre avec /forums à la place de /banale.
Problème, c'est que après avoir fais ça j'ai eu ce message :

Mauvais HTTP_REFERER. Si vous avez déplacé ces forums d'un endroit à un autre ou si vous avez changé de nom de domaine, vous devez mettre à jour manuellement l'URL de base dans la base de données (cherchez o_base_url dans la table config) et ensuite videz le cache en effaçant tous les fichiers .php du répertoire /cache.

Donc, je l'ai fais ! Mais j'ai vidé le cache avant d'avoir changé l'url, ça change quelque chose ?
Et ensuite, j'ai modifié l'url dans le Mysql. Et re-supprimé les 2 seuls fichiers qui se sont régénérés dans /cache.

J'ai rechanger l'url puis vidé le /cache dans l'ordre, mais j'ai toujours ce message d'erreur.
Si je veux, maintenant, ajouter une catégorie, un forum, ou autre, j'ai ce message à tous les coups :

Mauvais HTTP_REFERER. Vous avez été renvoyé sur cette page par une source inconnue ou interdite. Si le problème persiste, assurez-vous que le champ 'URL de base' de la page Admin/Options est correctement renseigné et que vous visitez ces forums en utilisant cette URL. Plus d'informations pourront être trouvées dans la documentation de FluxBB.

Que puis-je faire pour résoudre ce soucis ?
Je n'ai pas trouvé de réponses par rapport à ça dans le Forum..

Cordialement,

Hors ligne

#2 18-12-2009 19:10:37

adaur
Habitué actif

Re : Problème après changement d'URL.

Je pense que la nouvelle adresse n'est toujours pas rentrée dans l'esprit de FluxBB tongue

Je te suggère, même si c'est déjà fait, de procéder de la sorte :

1/ Modifie ta valeur dans Phpmyadmin
2/ Efface tous tes fichiers caches
3/ Modifie depuis le panel admin

Normalement, ça devrait marcher wink


"As code is more often read than written it's really important to write clean code." - Franz

Hors ligne

#3 18-12-2009 22:02:09

Ewaa
Membre

Re : Problème après changement d'URL.

Déjà fait plusieurs fois..
=S

Cordialement,

Hors ligne

#4 18-12-2009 22:06:17

adaur
Habitué actif

Re : Problème après changement d'URL.

Ewaa a écrit :

Déjà fait plusieurs fois..
=S

Cordialement,

Dans cet ordre, et refait tel qu'indiqué ?

J'en doute...


"As code is more often read than written it's really important to write clean code." - Franz

Hors ligne

#5 18-12-2009 22:55:14

Ewaa
Membre

Re : Problème après changement d'URL.

Je l'ai fais..
Mais aussi, dans /cache, je n'ai toujours plus que 3 fichier .php.

Cordialement,

Hors ligne

#6 18-12-2009 23:29:35

oldie-2
Habitué très actif

Re : Problème après changement d'URL.

Une simple hyphothèse : as-tu mis un slash à la fin de l'url ? si oui, il ne faut pas ...

Hors ligne

#7 18-12-2009 23:33:04

adaur
Habitué actif

Re : Problème après changement d'URL.

oldie-2 a écrit :

Une simple hyphothèse : as-tu mis un slash à la fin de l'url ? si oui, il ne faut pas ...

Très bonne remarque, j'y avais pas pensé big_smile !


"As code is more often read than written it's really important to write clean code." - Franz

Hors ligne

#8 19-12-2009 12:30:01

Ewaa
Membre

Re : Problème après changement d'URL.

oldie-2 a écrit :

Une simple hyphothèse : as-tu mis un slash à la fin de l'url ? si oui, il ne faut pas ...

Oui, j'en ai mis une.
Je vais réessayer de changer l'url pour autre chose, et ne pas mettre une slash à la fin.
Ensuite, vous ne savez toujours pas pourquoi je n'ai que 3 fichier dans /cache ?

Cordialement,

Hors ligne

#9 19-12-2009 12:47:12

oldie-2
Habitué très actif

Re : Problème après changement d'URL.

Ewaa a écrit :

Ensuite, vous ne savez toujours pas pourquoi je n'ai que 3 fichier dans /cache ?

Lesquels sont absents ?

Hors ligne

#10 19-12-2009 16:16:04

Ewaa
Membre

Re : Problème après changement d'URL.

Lol ?
C*nn*rie de nom de domaine ! happy
La team a acheté un nom de Domaine chez NitroServ, et du coup, je devais pas mettre l'url avec ce domaine, mais bien avec l'url de base, la vrai ! happy

Je m'excuse, merci à vous de votre patience !
(Je passe encore pour un con, mdrr !)

Cordialement,

Hors ligne

#11 21-03-2010 13:23:36

teopath
Habitué actif

Re : Problème après changement d'URL.

Bonjour

Envisageant un prochain changement url, je parcours  le forum à la recherche de la bonne méthode.

je suis sous la version 1.2.22

Le problème est que je n'ai pas d'entrée o_base_url  dans ma table config

Et j'ai parcouru les tables, pas de o_base_url nulle part

En la circonstance, que dois-je modifie ?

D'avance merci

Hors ligne

#12 21-03-2010 13:46:16

PascL
Habitué

Re : Problème après changement d'URL.

Le o_base_url est en page 2 de la table config.

Hors ligne

#13 21-03-2010 15:01:23

teopath
Habitué actif

Re : Problème après changement d'URL.

Je croyais qu'il y aurait des trucs à modiier dans config.php mais çà c'est pour la BDD

Donc si je résume, je modifie o_base_url dans la table config (page 2)
j'écrase le contenu du cache
je modifie dans administration/options

tous çà dans l'ordre

Et c'est suffisant ?

Hors ligne

#14 21-03-2010 17:04:05

Ewaa
Membre

Re : Problème après changement d'URL.

Si tu modifies o_base_url dans ta table config sur ton MySql, que tu vides le cache, normalement, il ne faut même plus passer dans l'administration.

Cordialement,

Hors ligne

Pied de page des forums