Archives FluxBB.fr

Les archives de FluxBB.fr

Recherche rapide

Vous n'êtes pas identifié(e).

Version 1.4.13 : [.tar.gz][.zip] (maj 20/10/2014)
Pack langue française pour 1.4.x : [.zip] (maj 06/01/2012)

Branche 1.5.x : fluxbb.org

Version 1.2.24 fr (entièrement en français) : [.zip] (maj 26/08/2011)
Pack langue française pour 1.2.x : [.zip] [.rar] (maj 15/10/2006)

Vous avez un problème ?
Avant de poser votre question sur les forums d'entraide nous vous invitons à consulter :

#26 05-12-2006 14:16:21

Gillou
Membre

Re : Intégration d'une partie du forum sur la page d'accueil de mon site

Effectivement, c'est bien la procédure que m'a indiqué Fredo et c'est bien ce que j'ai appliqué...

C'est pour cela que je ne vois vraiment pas ce qui ne va pas...

Puisque vous arrivez à récupérer les infos de mon forum et que moi non... selon, vous qu'est ce qui ne va pas dans ce que j'ai pu installer ? Spip ou PunBB ? Sous entendu, lequel devrais je réinstaller en priorité selon vous ?

Je serai tenter de dire Spip à première vue... mais bon, si vous voyez autre chose à tester avant une réinstallation, n'hésitez pas à me le dire !

Merci beaucoup en tout cas

Hors ligne

#27 05-12-2006 14:34:06

mangafan
Habitué très actif

Re : Intégration d'une partie du forum sur la page d'accueil de mon site

Bah là happy je sais pas trop.

Tu as quoi comme version de php et mysql sur ton serveur ? Quel type d'hébergement, ton php a-t-il des restrictions ou des fonctions désactivés qui empêchent Spip d'utiliser la syndication de contenu.

A mon avis, il faut que tu relèves l'erreur que Spip t'indique et que tu fouilles les forums de support de spip et google, peut-être que quelqu'un a eu le même problème et a la solution.

Dernière modification par mangafan (05-12-2006 14:34:52)


canon Mangafan : Mettez un chat dans votre processeur ! happy

Hors ligne

#28 05-12-2006 14:52:50

FredoMkb
Membre

Re : Intégration d'une partie du forum sur la page d'accueil de mon site

Re...

Gillou a écrit :

Puisque vous arrivez à récupérer les infos de mon forum et que moi non... selon, vous qu'est ce qui ne va pas dans ce que j'ai pu installer ? Spip ou PunBB ? Sous entendu, lequel devrais je réinstaller en priorité selon vous ?

Perso, je pense que c'est plutôt Spip que tu dois ré-installer, surtout que tu l'a déjà manipulé (déplacé) après la première installe, ce qui peut être, sous toute réserve, une cause paussible (plausible) de ce dysfonctionnement de syndication... d'autant que le syndication de ton forum PunBb à l'air de fonctionner chez moi par exemple...

à voir donc... tiens-nous au courant smile

Dernière modification par FredoMkb (05-12-2006 14:54:31)


Fredo d;o)
"Un pas à la fois me suffit..." (Gandhi)

Hors ligne

#29 05-12-2006 19:15:36

Gillou
Membre

Re : Intégration d'une partie du forum sur la page d'accueil de mon site

Bon et bien après désinstallation et réinstallation de spip, j'ai toujours le même problème... à se taper la tête contre les murs !

Pour répondre à Mangafan, mon site est hebergé chez PHPNet, hébergement mutualisée, php5 il me semble... aucune idée de la version de MySQL (j'ai récupéré le site et l'hébergement donc je ne sais pas tout...)

Ces fonctions php ont été désactivées récemment chez phpnet... je suis incapable de dire si cela a un lien quelconque avec ce problème :
glob, curl_exec, error_log, curl_int, tempnam, pcntl_exec, symlink


La galère...

Hors ligne

#30 06-12-2006 13:05:54

Gillou
Membre

Re : Intégration d'une partie du forum sur la page d'accueil de mon site

Je crois que le problème ne vient ni de Spip, ni de PunBB mais de mon hébergeur !!

J'ai trouvé ça ce matin, sur le forum de spip, d'une personne qui avait eu le même problème que moi voilà quelques mois :

http://forum.spip.org/fr_173896.html?var_recherche=RSS

(visiter le lien en bas de page)

En gros, il y a de fortes chances que la fonction d'inclusion d'une URL interne soit désactivée sur le serveur qui héberge mon site... je vais me renseigner !

En attendant, si quelqu'un voit une solution pour palier à ce problème, je suis preneur !

Dernière modification par Gillou (06-12-2006 13:06:15)

Hors ligne

#31 06-12-2006 16:14:34

Gillou
Membre

Re : Intégration d'une partie du forum sur la page d'accueil de mon site

Effectivement, mon problème se situe bel et bien à ce niveau sad

N'étant pas un pro en informatique, est ce que cela peut fonctionner avec RSS, PHP ou SSI de ne pas passer par une URL mais par /home/users/.../forums/extern.php?action=active&show=10   ?

J'ai essayé et ça ne marche pas franchement mais pourquoi ?

Hors ligne

#32 06-12-2006 19:54:30

mangafan
Habitué très actif

Re : Intégration d'une partie du forum sur la page d'accueil de mon site

La syndication marche avec des url car elles sert à avoir le contenu d'un site externe donc qui n'est pas dans l'arborescence de ton propre site.

Ca va se corser pour obtenir un résultat, il va falloir mettre du php dans le template de spip.


canon Mangafan : Mettez un chat dans votre processeur ! happy

Hors ligne

#33 07-12-2006 10:00:41

FredoMkb
Membre

Re : Intégration d'une partie du forum sur la page d'accueil de mon site

Bonjour Gillou et à tous smile

Gillou a écrit :

N'étant pas un pro en informatique, est ce que cela peut fonctionner avec RSS, PHP ou SSI de ne pas passer par une URL mais par /home/users/.../forums/extern.php?action=active&show=10 ?

J'ai deux pistes à te proposer... mais comme chez moi je n'ai pas les mêmes limitations que toi, je n'ai pu tester efficacement...

1. Puisque tes forums se trouvent à l'intérieur du répertoire de Spip, tu pourrais essayer de mettre une adrresse de syndication relative, de type :

forums/extern.php?action=active&type=RSS

Il ne s'agit plus d'une requête Http, ce qui est bloqué dans ton serveur, mais d'une adresse relative au fichier Php... seulement, je ne pense pas que les arguments présents dans l'adresse soient exploitables avec cette méthode (faudra tester)...

2. Si la première piste ne donne rien, à cause des arguments inexploitables, peut-être qu'on peut obtenir quelque chose en modifiant très légèrement le fichier nommé "extern.php", comme indiqué ci-après :

2.1. Après avoir édité le fichier "extern.php", retrouver le code suivant :

if (!isset($_GET['action']))
    exit('Aucun parametre de fourni. Veuillez voir extern.php pour les instructions.');

2.2. Commenter ce code pour obtenir :

/* if (!isset($_GET['action']))
    exit('Aucun parametre de fourni. Veuillez voir extern.php pour les instructions.'); */

2.3. Ajouter juste après le code commenté le code suivant :

if (!isset($_GET['action'])) {
    $_GET['action'] = 'active';
    $_GET['type'] = 'RSS';
}

2.4. Enfin, changer l'adresse de syndication dans les options de Spip par l'adresse relative suivante :

forums/extern.php

Petite explication... si jamais le passage d'arguments pose problème, alors on ne passe plus les valeurs dans l'adresse de syndication, mais on affecte ces valeurs directement dans le code du fichier "extern.php"...

Voilà, comme dit plus haut, je n'ai pu tester ces deux pistes, il m'est impossible de savoir si elles sont pertinentes ou pas...

J'espère que ça va fonctionner, tiens-nous au courant Stp...

Merci, à+ smile

Dernière modification par FredoMkb (08-12-2006 07:53:29)


Fredo d;o)
"Un pas à la fois me suffit..." (Gandhi)

Hors ligne

#34 07-12-2006 19:16:42

romain9441
Admin locker

Re : Intégration d'une partie du forum sur la page d'accueil de mon site

extern.php et pas externe.php ! wink


Avant de poser une question, avez-vous consulté la FAQ ou fait une recherche ?

Pas de support si pas d'adresse de forum !

Hors ligne

#35 08-12-2006 07:51:45

FredoMkb
Membre

Re : Intégration d'une partie du forum sur la page d'accueil de mon site

romain9441 a écrit :

extern.php et pas externe.php ! wink

Oups... huh désolé, j'ai pourtant bien relu mon post... pas suffisament visiblement... je corrige de suite pour qu'il n'y ait pas d'erreur...

Merci Romain smile


Fredo d;o)
"Un pas à la fois me suffit..." (Gandhi)

Hors ligne

#36 08-12-2006 14:32:11

Bernike
Nouveau Membre

Re : Intégration d'une partie du forum sur la page d'accueil de mon site

Gillou,
Je n'utilise pas SPIP mais mon hébergeur est Phpnet.
forums/extern.php?action=active&type=RSS fonctionne sous Firefox mais pas sous IE6.
forums/extern.php?action=active&show=15 fonctionne bien quel que soit le navigateur.
En espérant que cela puisse t'aider...

Hors ligne

#37 03-02-2007 21:14:31

Djo
Habitué actif

Re : Intégration d'une partie du forum sur la page d'accueil de mon site

Je post ici pour ne pas ouvrir un nouveau sujet smile
J'ai integré la liste des news de mon forum sur l'index de mon site, seulement, le lie ammene sur le dernier post du topic, et non pas sur le premier, la ou se trouve la news...
Merci et bonne soirée tongue

Hors ligne

#38 21-11-2008 17:28:21

tosca
Membre

Re : Intégration d'une partie du forum sur la page d'accueil de mon site

Bonjour à tous,

Je viens de constater que mon hébergeur (OVH, serveur mutualisé) n'autorisait pas le "allow_url_include" (j'aurais pourtant juré que ça fonctionnait il y a 10 jours ... soit ils ont modifié la configuration depuis, soit j'avais bu plus que de raison !)

Comment puis-je faire pour récupérer sur mon site le flux RSS de mon forum PunBB ?
Y a-t-il une autre solution que le include('http://www....) ? qui fonctionne hyper-bien ... mais en local pleure

Merci pour vos suggestions éclairées.

Hors ligne

#39 24-11-2008 17:47:36

Defaz
Habitué très actif

Re : Intégration d'une partie du forum sur la page d'accueil de mon site

Si il y a un truc je suis preneur aussi tongue

Hors ligne

#40 24-11-2008 20:25:26

oldie-2
Habitué très actif

Re : Intégration d'une partie du forum sur la page d'accueil de mon site

Bonsoir,

Est-ce que ce qui suit fonctionne chez ton hébergeur ?

$rss = @simplexml_load_file('http://...............................')
if ($rss !== false) 
{
     ob_start(); // on démarre la bufferisation de la page
     foreach ($rss->channel->item as $item) 
     { 
         echo '<a href="'.$item->link.'" target="_blank">'.$item->title.' ('.date('d-m-Y', strtotime($item->pubDate)).')</a><br />';
     } 
     $contenuRSS = ob_get_contents(); // on recupère le contenu du buffer 
     ob_end_flush();// on termine la bufferisation
    
}

Hors ligne

#41 25-11-2008 03:20:00

mangafan
Habitué très actif

Re : Intégration d'une partie du forum sur la page d'accueil de mon site

Oui cette méthode via [c]simplexml_load_file()[/c] fonctionne chez ovh en mutu je m'en sers pour le taff. wink

Je traite le résultat différemment car je suis obligé de re-pompé la page sur le ftp car le partenaire ne sait pas faire de xml valide (code xiti dans le flux et accents mal placés).

Mais pour ce qui est de l'essentiel ça marche.


canon Mangafan : Mettez un chat dans votre processeur ! happy

Hors ligne

#42 25-11-2008 09:08:13

tosca
Membre

Re : Intégration d'une partie du forum sur la page d'accueil de mon site

mangafan a écrit :

Oui cette méthode via [c]simplexml_load_file()[/c] fonctionne chez ovh en mutu je m'en sers pour le taff. wink

Merci pour le tuyau ; je suis provisoirement repassé en PHP4, qui ne pose pas de problème pour la récupération du flux RSS.
Mais je dois prochainement upgrader ma galerie photos, dont la nouvelle version va nécessiter PHP5, je vais donc devoir résoudre le problème de manière pérenne.

Hors ligne

Pied de page des forums