Archives FluxBB.fr

Les archives de FluxBB.fr

Recherche rapide

Vous n'êtes pas identifié(e).

Version 1.4.13 : [.tar.gz][.zip] (maj 20/10/2014)
Pack langue française pour 1.4.x : [.zip] (maj 06/01/2012)

Branche 1.5.x : fluxbb.org

Version 1.2.24 fr (entièrement en français) : [.zip] (maj 26/08/2011)
Pack langue française pour 1.2.x : [.zip] [.rar] (maj 15/10/2006)

Vous avez un problème ?
Avant de poser votre question sur les forums d'entraide nous vous invitons à consulter :

#1 31-08-2009 13:51:53

fanf73
Wik-wiki

Fluxbb 1.2.22

La version 1.2.22 de FluxBB vient d'être mise en ligne. Elle corrige quelques bugs mineurs et une vulnérabilité XSS.

Détails de changements
- Correction d'une faille critique XSS reportée par endeavormac
- Correction d'une alerte présente avec les nouvelles versions de PHP
- Correction d'une erreur lors de l'envoi d'avatar quand la restriction open_basedir est activée
- Les topics épinglés sont maintenant indiqués comme tels dans les résultats de recherche.

En raison de la faille XSS découverte, nous vous conseillons très vivement de mettre à jour votre forum dès que possible.

Hdiff
Patch files

N'oubliez pas de lancer le fichier 12_to_1222_update.php file après la mise à jour pour changer la version de votre forum.


Nous ne faisons pas le travail à votre place mais nous prenons le temps de vous montrer le chemin. Merci de lire ce que l'on vous dit et de réfléchir avant de re-demander une explication.

Hors ligne

#2 31-08-2009 14:09:12

abdellah
Membre

Re : Fluxbb 1.2.22

Merci bien wink

Hors ligne

#3 31-08-2009 18:16:55

Otomatic
Régisseur

Re : Fluxbb 1.2.22

Bonjour,

C'est quand même drôlement pratique un hdiff canon


Ce n'est pas parce que l'erreur se propage qu'elle devient vérité. Gandhi

Hors ligne

#4 31-08-2009 19:40:31

M@x
Habitué très actif

Re : Fluxbb 1.2.22

fanf73 a écrit :

- Les topics épinglés sont maintenant indiqués comme tels dans les résultats de recherche.

Merci qui ?! Picard

Il faudrait que je mette mes forums en 1.2.20 à jour moi...


...

Hors ligne

#5 31-08-2009 20:57:49

adaur
Habitué actif

Re : Fluxbb 1.2.22

C'est la première fois que je mets à jour un PunBB...

J'ai sûrement du louper un truc...

J'ai fait toutes les modifs du hdiff à la main, et pourtant lors de la recherche de MAJ, j'ai toujours comme quoi je ne possède pas la dernière version sad

HS : j'ai un souci sur la recherche d'épinglé : Il n'y a pas marqué le "Epinglé :" mais juste ":" hmm

Solution : charger le fichier de langue.

Ajouter :

// Load the forum.php language file
require PUN_ROOT.'lang/'.$pun_user['language'].'/forum.php';

Dernière modification par adaur31 (31-08-2009 21:10:18)


"As code is more often read than written it's really important to write clean code." - Franz

Hors ligne

#6 31-08-2009 23:05:57

Spiky
Habitué

Re : Fluxbb 1.2.22

adaur31 a écrit :

C'est la première fois que je mets à jour un PunBB...

J'ai sûrement du louper un truc...

J'ai fait toutes les modifs du hdiff à la main, et pourtant lors de la recherche de MAJ, j'ai toujours comme quoi je ne possède pas la dernière version sad

Puisque tu as fait les modifications a la mimine, il ne faut pas oublier de mettre a jour la version dans la base via phpmyadmin (ou autres) MAIS dans un premier temps :

Executer le fichier : 12_to_1222_update.php
pour mettre a jour la version du .org

Puis pour la VF : config -> o_cur_version_fr -> mettre conf_value à 1.2.22
(puisque que la vf n'est pas présente ici pour le fichier update)

[Edit] Bon effectivement même en faisant ça, cela ne change rien !!! (pourtant la maj me met ok avec le fichier update) et tout est bien renseigné dans la base, elle est bien passé en 1.2.22). Vidage du cache effectué également.
Et toujours ce message (pour le .org) "Une nouvelle version de FluxBB est disponible ! Vous pouvez télécharger cette dernière version sur FluxBB.org.".

Dernière modification par Spiky (01-09-2009 01:17:20)


I do not play against a team in particular. I play to fight against the idea to lose... Life is beautiful.

Hors ligne

#7 01-09-2009 00:59:04

M@x
Habitué très actif

Re : Fluxbb 1.2.22

Bizarre ça. Tu as bien vérifié la valeur de o_cur_version dans ton fichier cache ?


...

Hors ligne

#8 01-09-2009 01:19:27

Spiky
Habitué

Re : Fluxbb 1.2.22

M@x a écrit :

Bizarre ça. Tu as bien vérifié la valeur de o_cur_version dans ton fichier cache ?

Oui il est ok

<?php

define('PUN_CONFIG_LOADED', 1);

$pun_config = array (
  'o_cur_version' => '1.2.22',
  'o_cur_version_fr' => '1.2.22',

I do not play against a team in particular. I play to fight against the idea to lose... Life is beautiful.

Hors ligne

#9 01-09-2009 04:28:03

Mpok
Néo Admin

Re : Fluxbb 1.2.22

Ouais, c'est bizarre... huh
Même ici , le problème existe (alors que la maj n'a pas encore été effectuée, donc le message est normal en testant le .org, mais anormal en testant le.fr).
EDIT : pbm de cache...

Je pense que cela vient de la "double gestion de version" (org et fr), mais je ne vois pas où...
En particulier, le cas Spiky est illogique : si o_cur_version_fr est bien à 1.2.22, il ne devrait pas y avoir de pbm (même si aujourd'hui, nous sommes encore à 1.2.21 ici).

Edit : ok, ça marche ici (nouvelle version .org, good version .fr).


Life is a struggle, programming is a suffer.

Hors ligne

#10 01-09-2009 04:38:08

Mpok
Néo Admin

Re : Fluxbb 1.2.22

Ahh, ben évidemment...

IL Y A UN BUG DANS LE HDIFF !!!

Fichier admin_index.php, dans la ligne "version_compare", remplacer les '.' par des ','


Life is a struggle, programming is a suffer.

Hors ligne

#11 01-09-2009 05:26:04

Spiky
Habitué

Re : Fluxbb 1.2.22

Mpok a écrit :

Ahh, ben évidemment...

IL Y A UN BUG DANS LE HDIFF !!!

Fichier admin_index.php, dans la ligne "version_compare", remplacer les '.' par des ','

Dans la ligne que tu cites, j'avais déjà les ","
Mon problème reste le même.
Et mon o_cur_version_fr est bien à 1.2.22

(je parle pour le .org, le fr était "bon" des le départ, c'est moi qui ai modif dans la base en 1.2.22 vu que le .fr était en 1.2.21 donc le problème ne ce posait pas)

Pourtant quand je test : http://fluxbb.org/latest_version il indique bien 1.2.22 !!!!

Donc ca vient de l'action ../admin_index.php?action=check_upgrade

Dernière modification par Spiky (01-09-2009 05:34:50)


I do not play against a team in particular. I play to fight against the idea to lose... Life is beautiful.

Hors ligne

#12 01-09-2009 05:45:45

Spiky
Habitué

Re : Fluxbb 1.2.22

J'ai vu ton passage sur le .org  (really need glasses) tongue

Bon c'est le fichier fr qui va pas :

remplacer dans admin_index.php  :

// Check for upgrade
if ($action == 'check_upgrade')
{
    if (!ini_get('allow_url_fopen'))
        message('Impossible de vérifier les mises à jour tant que \'allow_url_fopen\' est désactivé sur ce système.');

    $latest_version = trim(@file_get_contents('http://fluxbb.org/latest_version'));
    if (empty($latest_version))
    @fclose($fp);

    if ($latest_version == '')
        message('La vérification de mise à jour a échouée pour une raison inconnue.');

    if (version_compare($pun_config['o_cur_version'], $latest_version, '>='))
    $cur_version = (strlen($cur_version) == 2) ? intval($cur_version) * 10 : intval($cur_version);

    $latest_version = str_replace('.', '', strtolower($latest_version));
    $latest_version = (strlen($latest_version) == 2) ? intval($latest_version) * 10 : intval($latest_version);

    if ($cur_version >= $latest_version)
        message('Vous utilisez la dernière version de FluxBB.');
    else
        message('Une nouvelle version de FluxBB est disponible ! Vous pouvez télécharger cette dernière version sur <a href="http://fluxbb.org/">FluxBB.org</a>.');
}

par :

// Check for upgrade

if ($action == 'check_upgrade')
{
    if (!ini_get('allow_url_fopen'))
        message('Impossible de vérifier les mises à jour tant que \'allow_url_fopen\' est désactivé sur ce système.');

    $latest_version = trim(@file_get_contents('http://fluxbb.org/latest_version'));
    if (empty($latest_version))
        message('La vérification de mise à jour a échouée pour une raison inconnue.');

    if (version_compare($pun_config['o_cur_version'], $latest_version, '>='))
        message('Vous utilisez la dernière version de FluxBB.');
    else
        message('Une nouvelle version de FluxBB est disponible ! Vous pouvez télécharger cette dernière version sur <a href="http://fluxbb.org/">FluxBB.org</a>.');
}

Et la c'est OK big_smile

[Edit] pour ceux qui ont fait la modif avec le hdiff, adaur31 en particulier

Dernière modification par Spiky (01-09-2009 06:20:52)


I do not play against a team in particular. I play to fight against the idea to lose... Life is beautiful.

Hors ligne

#13 01-09-2009 06:02:54

Mpok
Néo Admin

Re : Fluxbb 1.2.22

Ok, il n'y a donc PAS DE BUG...

En appliquant le hdiff ici-même (sur admin_index.php), ET en appliquant la même modif sur le code "spécifique fr" (ce qui, grosso-modo ne change pas grand-chose, mais tant qu'à faire..), j'obtiens un résultat CORRECT, soit :
- vérification .org : "nouvelle version disponible".
- vérification .fr : "vous utilisez la dernière version".

Donc, ça marche (ici).
(pour l'instant, je suis encore en 1.2.21).

Et donc, je ne comprends pas d'où vient ton pbm Spiky... huh
Bon, ceci dit, je n'ai pas encore fait le même test que toi : il faudrait que je passe officiellement en 1.2.22.. On verra demain.. (au pire je ferai un test, même sans faire la maj elle-même).


Life is a struggle, programming is a suffer.

Hors ligne

#14 01-09-2009 06:07:14

Spiky
Habitué

Re : Fluxbb 1.2.22

réglé voir plus haut wink


I do not play against a team in particular. I play to fight against the idea to lose... Life is beautiful.

Hors ligne

#15 01-09-2009 09:40:00

adaur
Habitué actif

Re : Fluxbb 1.2.22

Sans exécuter le 12to1222.php qui vient de je ne sais pas ou (le .patch à renommer ? erreur de synthaxe pour moi), en appliquant les modifs de Spiky, en modifiant dans la bdd et en supprimant le cache, ça plane pour moi big_smile


"As code is more often read than written it's really important to write clean code." - Franz

Hors ligne

#16 01-09-2009 10:03:37

teopath
Habitué actif

Re : Fluxbb 1.2.22

Est il nécessaire d'iploader tous les fichiers corrigés en même temps ?

Ou la mise à jour peut elle s'effectuer fichier par fichier ?

Par exemple, j'ai mis à jour admin_index.php, çà ne traite que de la version de fluxBB, çà ne doit pas être très interdépendant des autres fichier.

Hors ligne

#17 01-09-2009 10:36:56

adaur
Habitué actif

Re : Fluxbb 1.2.22

Perso j'ai mis mon fofo en maintenance, et fichier par fichier wink


"As code is more often read than written it's really important to write clean code." - Franz

Hors ligne

#18 01-09-2009 11:12:39

teopath
Habitué actif

Re : Fluxbb 1.2.22

Pour l'instant, index_admin, c'est la version
prune_admin, çà force une variable qui était récupérée par méthode POST, donc pas grand chandement

dans common çà rajoute un test qui ne change rien

Là je continue avec functions

Hors ligne

#19 01-09-2009 14:18:05

Krabator
Régulier

Re : Fluxbb 1.2.22

arg... pas le temps de voir les modifs du hdiff.

Après tout cela, est ce que le premier hdiff est le bon ou est ce qu'il faut rajouter les script ci - dessus ?

Hors ligne

#20 01-09-2009 15:29:07

adaur
Habitué actif

Re : Fluxbb 1.2.22

Krabator a écrit :

arg... pas le temps de voir les modifs du hdiff.

Après tout cela, est ce que le premier hdiff est le bon ou est ce qu'il faut rajouter les script ci - dessus ?

Je te résume tout smile

Fais ce que te dis le hdiff, puis ce que tu dis Spiky, change la version dans ta base de données (1.2.21 > 1.2.22 dans config : o_cur_version et o_cur_version_fr), et enfin efface tes fichiers cache.

Régénère-les en envoyant la config sans rien toucher de admin_options.

Le tour est joué smile


"As code is more often read than written it's really important to write clean code." - Franz

Hors ligne

#21 01-09-2009 15:40:28

teopath
Habitué actif

Re : Fluxbb 1.2.22

Pas tout compris là

D'abord c'est quoi ces fichiers cache dont tout le monde parle, ils sont où ?

Et on envoie la config de quoi ?

Et le fichier  : 12_to_1222_update.php , on le trouve où ?

Dernière modification par teopath (01-09-2009 15:42:10)

Hors ligne

#22 01-09-2009 15:41:53

adaur
Habitué actif

Re : Fluxbb 1.2.22

Fichiers cache : fichiers présents dans le dossier bien nommé 'cache' de PunBB.

La config, tu vas juste dans les options, tu ne touche à rien, et tu fais 'Envoyer'.

Ca va les régénérer avec les nouvelles valeurs wink


"As code is more often read than written it's really important to write clean code." - Franz

Hors ligne

#23 01-09-2009 15:47:40

Krabator
Régulier

Re : Fluxbb 1.2.22

Merci à toi, adaur31

Hors ligne

#24 01-09-2009 16:43:08

teopath
Habitué actif

Re : Fluxbb 1.2.22

Ok, merci

Hors ligne

#25 01-09-2009 17:13:15

teopath
Habitué actif

Re : Fluxbb 1.2.22

Et :

12_to_1222_update.php

On le trouve où celui là ?

Hors ligne

Pied de page des forums