Archives FluxBB.fr

Les archives de FluxBB.fr

Recherche rapide

Vous n'êtes pas identifié(e).

Version 1.4.13 : [.tar.gz][.zip] (maj 20/10/2014)
Pack langue française pour 1.4.x : [.zip] (maj 06/01/2012)

Branche 1.5.x : fluxbb.org

Version 1.2.24 fr (entièrement en français) : [.zip] (maj 26/08/2011)
Pack langue française pour 1.2.x : [.zip] [.rar] (maj 15/10/2006)

Vous avez un problème ?
Avant de poser votre question sur les forums d'entraide nous vous invitons à consulter :

#26 24-04-2009 22:32:07

Mr.Sheridan
Membre

Re : [Mod] Avertissement par ifl-limited.com version 0.8b

kardoc a écrit :
Mr.Sheridan a écrit :

Bonjour,

mysqli n'est qu'une simple extention PHP de mysql dit "amélioré" et non une version de mysql ou un SGDB à part entière.

Merci de l'info, j'étais pas sur de la différence entre les 2.

Je viens de modifier install_mod pour qu'il prend aussi le mysql

la variable $db_type est déjà incluse

Au temps pour moi dans ce cas ! smile

Dernière modification par Mr.Sheridan (24-04-2009 22:32:22)

Hors ligne

#27 27-04-2009 13:30:04

Mattt07
Régulier

Re : [Mod] Avertissement par ifl-limited.com version 0.8b

je retire kardoc, je viens de retester à l instant tongue

pourquoi avant hier ça ne marchait pas, mystère...

installé sr mon forum ! c'est parfait ! merciiiii bcp

Dernière modification par Mattt07 (27-04-2009 13:52:21)

Hors ligne

#28 15-05-2009 14:14:55

linkshoot
Membre

Re : [Mod] Avertissement par ifl-limited.com version 0.8b

Bonjour j'ai testé votre mod j'ai une erreur au plugins

Fatal error: Cannot redeclare generate_config_cache() (previously declared in /le chemain de mon fofo/include/cache.php:81) in /le chemain de mon fofo/include/cache.php on line 96


Voila mon code cache ligne 76 à 96;


//
// Generate the config cache PHP script
//
function generate_config_cache()
{
    global $db;

    // Get the forum config from the DB
    $result = $db->query('SELECT * FROM '.$db->prefix.'config', true) or error('Unable to fetch forum config', __FILE__, __LINE__, $db->error());
    while ($cur_config_item = $db->fetch_row($result))
        $output[$cur_config_item[0]] = $cur_config_item[1];

    // Output config as PHP code
    $fh = @fopen(PUN_ROOT.'cache/cache_config.php', 'wb');
    if (!$fh)
        error('Unable to write configuration cache file to cache directory. Please make sure PHP has write access to the directory \'cache\'', __FILE__, __LINE__);

    fwrite($fh, '<?php'."\n\n".'define(\'PUN_CONFIG_LOADED\', 1);'."\n\n".'$pun_config = '.var_export($output, true).';'."\n\n".'?>');

    fclose($fh);
}

Dernière modification par linkshoot (15-05-2009 14:49:59)

Hors ligne

#29 15-05-2009 18:01:37

M@x
Habitué très actif

Re : [Mod] Avertissement par ifl-limited.com version 0.8b

Message d'erreur indiquant que le fonction est appelé deux fois dans le code (Impossible d'avoir deux fonction de même nom)

Du as surement fait une erreur lors de l'installation de la mod. wink


...

Hors ligne

#30 15-05-2009 18:26:17

linkshoot
Membre

Re : [Mod] Avertissement par ifl-limited.com version 0.8b

edit: ok merci max je vais reprendre à zéro

Par contre c'est pas le plugins qui demande 2 fois la même chose ?

Dernière modification par linkshoot (15-05-2009 18:36:44)

Hors ligne

#31 15-05-2009 19:23:04

kardoc
Régulier

Re : [Mod] Avertissement par ifl-limited.com version 0.8b

Tu as prit quel version ? Je viens de vérifie la 0.8c, il y a un seul appelle à cette fonction.

Hors ligne

#32 15-05-2009 20:18:31

linkshoot
Membre

Re : [Mod] Avertissement par ifl-limited.com version 0.8b

Bonsoir kardoc en faite j'avais la 0.8 et la je vient de testé la 0.9 et pareil.

Je vais testé plus tard dans la soirée sur un forum pas modser (je c'est pas si ça se dit hmm )

Hors ligne

#33 16-05-2009 01:13:14

M@x
Habitué très actif

Re : [Mod] Avertissement par ifl-limited.com version 0.8b

Tu as le message que sur cette page ? Si oui transmet la moi par mail, ou bien up la sur ton FTP en .txt wink


...

Hors ligne

#34 17-05-2009 17:25:36

linkshoot
Membre

Re : [Mod] Avertissement par ifl-limited.com version 0.8b

Désoler de pas avoir répondue avant j'ai eu du monde se week-end.

je n'est pas eu le temps de le faire sur un fofo d'origine, je vient pour te répondre en attendent que je teste.

alors oui Max ça me le fait que sur cette page don voila le fichier comme tu ma demander AvertissementV09.txt

Pour plus de faciliter je te les mis en archive aussi change txt par rar.

Hors ligne

#35 17-05-2009 19:30:40

M@x
Habitué très actif

Re : [Mod] Avertissement par ifl-limited.com version 0.8b

Remplace dans ce fichier

require PUN_ROOT.'include/cache.php';

Par

# require PUN_ROOT.'include/cache.php';

...

Hors ligne

#36 17-05-2009 22:08:38

linkshoot
Membre

Re : [Mod] Avertissement par ifl-limited.com version 0.8b

Super ça marche smile merci max.

Petite suggestion, ça serrai bien que quand on modifie le nombre de bannissement, quand on avertie et retire un avertissement  qu'il y est une redirection ou un lien retour.

Dernière modification par linkshoot (17-05-2009 22:14:39)

Hors ligne

#37 17-05-2009 22:14:50

M@x
Habitué très actif

Re : [Mod] Avertissement par ifl-limited.com version 0.8b

Remplace les phrases du genre :

echo 'L\'utilisateur '.htmlentities($avertissement_username).' est désormais banni de ce forum.';

Par

redirect('admin_index.php', 'L\'utilisateur '.htmlentities($avertissement_username).' est désormais banni de ce forum.');

...

Hors ligne

#38 23-05-2009 21:45:37

linkshoot
Membre

Re : [Mod] Avertissement par ifl-limited.com version 0.8b

Ok merci max je vais testé

Hors ligne

#39 09-07-2009 09:55:43

Krabator
Régulier

Re : [Mod] Avertissement par ifl-limited.com version 0.8b

bonjour,

j'ai l'impression que la notice d'installation comporte une erreur dés la création des tables.

Ne faut il pas modifier :

ALTER TABLE pun_users ADD nb_avertissement_authorised bigint(1) NOT NULL default '0';

par :

ALTER TABLE pun_users ADD nb_avertissement bigint(1) NOT NULL default '0';

Je trouve que c'est bizarre sinon...

Après, ici :

//Ajouter après ://
-----------------
, nb_avertissement

je mettrais plutot

//Ajouter après ://
-----------------
, u.nb_avertissement

Hors ligne

#40 22-07-2009 22:40:18

Yugo265
Nouveau Membre

Re : [Mod] Avertissement par ifl-limited.com version 0.8b

Bonjour à tous.

Le Mod marche à merveille et nous tenons à remercier les personnes ayant travailler dessus, ainsi que les personnes y ayant contribuer.

Je souaiterais juste apporter un petit plus, pour le cas ou si un jour, vous faites une mise à jour, et si se n'est pas trop compliqué à faire, de pouvoir rajouter ceci :

~ Plus d'avertissement qu'une limite de 9.
~ De pouvoir y apposer en même temps un bannissement de X heures.

Pourquoi ? Tout simplement parce que j'estime qu'un avertissement se doit d'être accompagné d'une santion.

Bien évidemment, je peux bannir. Mais celà m'oblige à faire de la manipulation.
(Un coup dans bannissement et un coup dans avertissement.) Associer les deux en 1 serais apréciable.

Voilà ce que je fais pour l'instant :

1er Avertissement : Bannissement jusqu'à la fin de la journée 00H00.
2ème Avertissement : Bannissement jusqu'à la fin de la journée 00H00.
3ème Avertissement : Bannissement jusqu'au lendemain 00H00.
4ème Avertissement : Bannissement jusqu'au lendemain 00H00.
5ème Avertissement : Bannissement de 8 jours.
6ème Avertissement : Bannissement de 8 jours.
7ème Avertissement : Bannissement de 15 jours.
8ème Avertissement : Bannissement de 15 jours.
9ème Avertissement : Bannissement définitif.

En espérant pouvoir apporter ma pierre à l'édifice.

A peluche.


Il est plus facile de dire que l'on a raison plutôt que d'expliquer pourquoi l'on a pas tord. Pierre Dac.

Hors ligne

#41 30-08-2009 21:34:10

adaur
Habitué actif

Re : [Mod] Avertissement par ifl-limited.com version 0.8b

Mod installée, pas de bug pour le moment smile

Sinon, quel intérêt de rentrer une raison de l'averto si il n'est pas affiché dans le profil ?


"As code is more often read than written it's really important to write clean code." - Franz

Hors ligne

#42 23-09-2009 17:59:43

Filou69
Membre

Re : [Mod] Avertissement par ifl-limited.com version 0.8b

adaur31 a écrit :

Mod installée, pas de bug pour le moment smile

Sinon, quel intérêt de rentrer une raison de l'averto si il n'est pas affiché dans le profil ?

Peut-être pour se rappeler de la cause de l'avertissement ... happy

Hors ligne

#43 23-09-2009 18:54:30

adaur
Habitué actif

Re : [Mod] Avertissement par ifl-limited.com version 0.8b

Filou69 a écrit :
adaur31 a écrit :

Mod installée, pas de bug pour le moment smile

Sinon, quel intérêt de rentrer une raison de l'averto si il n'est pas affiché dans le profil ?

Peut-être pour se rappeler de la cause de l'avertissement ... happy

Pas présent non plus dans le panel admin Oo

=> Bug résolu

Dernière modification par adaur31 (02-10-2009 19:12:56)


"As code is more often read than written it's really important to write clean code." - Franz

Hors ligne

#44 02-10-2009 19:32:06

GRiBOU
Régulier

Re : [Mod] Avertissement par ifl-limited.com version 0.8b

Est-ce que quelqu'un peut proposer cette mod corrigée pcq j'ai des bugs sad

Hors ligne

#45 02-10-2009 20:46:38

kardoc
Régulier

Re : [Mod] Avertissement par ifl-limited.com version 0.8b

GRiBOU a écrit :

Est-ce que quelqu'un peut proposer cette mod corrigée pcq j'ai des bugs sad

Sympa de dire que tu as des bug, mais si tu dit pas lequel, comment veux tu qu'il soit corriger !!!
En plus, rien ne nous dit que les bug ne viens pas de chez toi, donc

AUCUNE INDICATION = AUCUNE AIDE

Hors ligne

#46 02-10-2009 21:09:41

GRiBOU
Régulier

Re : [Mod] Avertissement par ifl-limited.com version 0.8b

J'ai réussi à corriger les bugs grâce à Adaur wink

Il suffisait simplement de remplacer partout nb_avertissement par nb_avertissement_authorised

Hors ligne

#47 02-10-2009 21:18:56

kardoc
Régulier

Re : [Mod] Avertissement par ifl-limited.com version 0.8b

kardoc a écrit :
GRiBOU a écrit :

Est-ce que quelqu'un peut proposer cette mod corrigée pcq j'ai des bugs sad

Sympa de dire que tu as des bug, mais si tu dit pas lequel, comment veux tu qu'il soit corriger !!!
En plus, rien ne nous dit que les bug ne viens pas de chez toi, donc

AUCUNE INDICATION = AUCUNE AIDE

PS : le prend pas mal smile

Hors ligne

#48 02-10-2009 21:20:28

GRiBOU
Régulier

Re : [Mod] Avertissement par ifl-limited.com version 0.8b

Aucun souci, ne t'en fais pas, je l'ai pas mal prit du tout étant donné que tu as raison...

Hors ligne

#49 03-10-2009 19:04:48

General Otacon
Membre

Re : [Mod] Avertissement par ifl-limited.com version 0.8b

Moi quand je l'ai installé et je veux modifier le nombre d'avertissement sa fait Retirer un avertissement Erreur interne du système d'avertissement, code 014 et dans profil
An error was encountered
Error: Unable to fetch user info.
Je dois faire quoi?

Hors ligne

#50 03-10-2009 19:08:14

adaur
Habitué actif

Re : [Mod] Avertissement par ifl-limited.com version 0.8b

General Otacon a écrit :

Moi quand je l'ai installé et je veux modifier le nombre d'avertissement sa fait Retirer un avertissement Erreur interne du système d'avertissement, code 014 et dans profil
An error was encountered
Error: Unable to fetch user info.
Je dois faire quoi?

http://www.punbb.fr/forums/viewtopic.ph … 706#p81706 ceci happy


"As code is more often read than written it's really important to write clean code." - Franz

Hors ligne

Pied de page des forums