Archives FluxBB.fr

Les archives de FluxBB.fr

Recherche rapide

Vous n'êtes pas identifié(e).

Version 1.4.13 : [.tar.gz][.zip] (maj 20/10/2014)
Pack langue française pour 1.4.x : [.zip] (maj 06/01/2012)

Branche 1.5.x : fluxbb.org

Version 1.2.24 fr (entièrement en français) : [.zip] (maj 26/08/2011)
Pack langue française pour 1.2.x : [.zip] [.rar] (maj 15/10/2006)

Vous avez un problème ?
Avant de poser votre question sur les forums d'entraide nous vous invitons à consulter :

#1 12-12-2006 06:46:08

Dave
Membre

PunOogle pour 1.2.14 tout pret 1.0

Auteur : PunOogle

Bonjour,

Je viens d'arriver sur ce forum et la premiere chose que j'ai faites c'est le Url-rewriting pour m'apercevoir que c'était la galere de parcourir les divers posts/pages et sujets!

Alors ma premiere contribution est la suivante: Un PunOogle tout fait et fonctionnel d'un premier jet... Donc plus besoin de prendre des heures a parcourir les divers posts ainsi que les diverses modifications! Toute les modifs sont deja faites dans mon zip (ce qui concerne que les fichiers modifiés bien sur).

Bravo a Punbb-fr! big_smile

Hors ligne

#2 12-12-2006 12:27:51

vin100
Habitué très actif

Re : PunOogle pour 1.2.14 tout pret 1.0

salut,

Dave a écrit :

Toute les modifs sont deja faites dans mon zip (ce qui concerne que les fichiers modifiés bien sur).

si je comprend bien tu as mis les fichiers modifiés dans ton zip et il suffit de remplacer nos fichiers par ceux que tu fournis ?

Hors ligne

#3 12-12-2006 14:09:09

Djo
Habitué actif

Re : PunOogle pour 1.2.14 tout pret 1.0

J'aimerai bien l'installé mais il concerne certains fichiers que j'ai déjà modifié hmm

Dernière modification par Djo (12-12-2006 14:09:24)

Hors ligne

#4 12-12-2006 14:09:21

Tommyl
Régulier

Re : PunOogle pour 1.2.14 tout pret 1.0

Je n'ai pas bien compris non plus...

Mais si c'est le cas, c'est pas fort pratique pour les gens ayant un forum modifié déjà hmm

Hors ligne

#5 12-12-2006 15:18:00

Morph1er
Habitué actif

Re : PunOogle pour 1.2.14 tout pret 1.0

Salut,

Comme pour la mod de tcheval, il manque des choses à rewriter.
Je donne des éléments ici :
http://www.punbb.fr/forums/viewtopic.ph … 752#p27752

Tu devrai t'inspirer du mod de tcheval, il marche plutôt bien wink.

Hors ligne

#6 12-12-2006 15:42:30

romain9441
Admin locker

Re : PunOogle pour 1.2.14 tout pret 1.0

De la mod ! wink


Avant de poser une question, avez-vous consulté la FAQ ou fait une recherche ?

Pas de support si pas d'adresse de forum !

Hors ligne

#7 12-12-2006 17:32:45

Dave
Membre

Re : PunOogle pour 1.2.14 tout pret 1.0

Zip mis a jour, merci Morph1er!

(Morph1er) Merci j'avais zappé parmis les milliers de post a ce sujet. smile

(vin100) Oui mon zip remplace que les fichiers qui sont atteints.

(Tommyl) Heu... Il est évident que le zip s'applique qu'aux fichiers deja existants, donc si tu les as deja modifiés avec d'autres mods c'est normal que tu rale...

Mon zip arrive tout droit d'un installation fraiche. Donc la premiere mods c'est le mod-rewrite. Apres cela, et bien normal que vous etes seul au commande! Je pensais vraiment pas a avoir eu besoin de le dire...:huh:

Dernière modification par Dave (12-12-2006 17:33:35)

Hors ligne

#8 12-12-2006 18:25:14

vin100
Habitué très actif

Re : PunOogle pour 1.2.14 tout pret 1.0

Je suis assez du même avis que Tommyl et c'est pour ça que je te posais la question. Beaucoup de personnes ont d'ores et déjà des mods installées. Tu peut pas dire à ces personnes "c'est la première mod que vous devez installer" ; ces personnes n'installeront donc pas ta mod. Généralement ceux qui installent des mods n'en installent pas qu'une. De plus le jours où une nouvelle version de PunBB sort, si jamais elle touche aux mêmes fichiers que ta mod alors cette dernière sera périmée. De plus pour quelqu'un qui ne s'y connais pas il va remplacer directement les fichiers sans chercher à comprendre, si il avait installé d'autres mods auparavant ça va être la misère, il va venir ici en criant pourquoi son forum marche plus. C'est pour cela que nous faisons des fichiers d'installation de mod en indiquant précisément ce qu'il faut modifier, pas pour faire suer les utilisateurs.

Hors ligne

#9 12-12-2006 19:13:44

Dave
Membre

Re : PunOogle pour 1.2.14 tout pret 1.0

c'est pour cela que le readme.txt dans mon zip existe... tout les mods sont expliqués deja, ligne par ligne... sad

Faire un mod tout fait SANS modifier aucun fichier ca s'appelle pas un mod mais une version nouvelle. Vu que punbb n'existe pas encore avec l'option a la volé du rewriting inclus dedans.

Je me rend compte qu'a trop vouloir aider, personne appréci. La prochaine fois je garde mes mods et skins pour moi. sujet clos. smile

Dernière modification par Dave (12-12-2006 19:14:27)

Hors ligne

#10 12-12-2006 19:23:23

Ishido
Habitué actif

Re : PunOogle pour 1.2.14 tout pret 1.0

Tu dois aussi comprendre le point de vue de l'utilisateur.
Ton intention est louable.
On prend tes fichiers, on écrase les fichiers et hop! c'est installé.
Sauf que, comme expliqué plus haut, pour la plupart, nous avons déjà commencé à personnaliser nos forums.
De plus, quand une personne propose une MOD, elle ne "mâche" pas le travail à ses éventuels futurs utilisateurs. Elle écrit simplement un fichier "readme.txt" dans lequel sont indiquées, étape par étape, les modifications à effectuer.
Je suis là depuis peu et il en a toujours été ainsi.

J'espère que tu comprendras ce point de vue et que tu continueras a nous faire partager ton enthousiasme et tes connaissances en programmation.

Amicalement. smile


Chez Wam
Message tapé en Bépo avec un TypeMatrix 2030 USB smile

Hors ligne

#11 12-12-2006 19:23:46

Tommyl
Régulier

Re : PunOogle pour 1.2.14 tout pret 1.0

Ne le prends pas ainsi.

Je n'ai pas télécharger ton mod, je n'ai fais que lire ce que tu as donné et j'ai compris la même chose que vin100.

Maintenant, si dans le mod, il y a les fichiers modifiés pour une installation toute fraiche et un readme expliquant la démarche à suivre pour installer la mod pour d'autres, c'est niquel. Je répète que je n'ai pas téléchargé la mod donc je ne sais dire si c'est le cas.

Mais faut pas en faire tout un plat non plus :-) J'espère pour toi que tu crées les mods pour toi au départ et ensuite pour les autres, donc si c'est le cas, ça te sert forcément donc l'avis des autres tu t'en balances un peu ;p

Hors ligne

#12 12-12-2006 20:02:50

vin100
Habitué très actif

Re : PunOogle pour 1.2.14 tout pret 1.0

pisque c'est ça j'donnerais pus mon avis et j'conseillerais pus, na! siffle tongue

Hors ligne

#13 12-12-2006 20:04:27

romain9441
Admin locker

Re : PunOogle pour 1.2.14 tout pret 1.0

Ohhh!

Vin100 fait son boudin ! siffle


Avant de poser une question, avez-vous consulté la FAQ ou fait une recherche ?

Pas de support si pas d'adresse de forum !

Hors ligne

#14 12-12-2006 20:48:37

Dave
Membre

Re : PunOogle pour 1.2.14 tout pret 1.0

Tommyl a écrit :

Ne le prends pas ainsi.

Mais faut pas en faire tout un plat non plus :-) J'espère pour toi que tu crées les mods pour toi au départ et ensuite pour les autres, donc si c'est le cas, ça te sert forcément donc l'avis des autres tu t'en balances un peu ;p

Je n'en fait pas 'tout un plat' comme tu dit. Je suis direct et prompt (mes clients aiment cela d'ailleur). C'est surement une question de mentalité et/ou d'age alors car a voir ma bonne intention de depart se faire critiquer ensuite... Ca donne pas le gout de poursuivre.

La mentalité US est fort différente, au lieu de dénigrer, ils ajoutent positivement des choses que le poste original aurait oublié. D'ou le sens d'entraide réel.

Bref, je me rend compte que c'est surement une question de culture/mentalité plus que autre chose...

bonne chance dans vos mods. big_smile

Hors ligne

#15 12-12-2006 23:08:26

vin100
Habitué très actif

Re : PunOogle pour 1.2.14 tout pret 1.0

Franchement c'est du délire. On t'as juste donné des conseils pour optimiser ta mod de façon à ce que personne ne soit lésé et tu prend ça comme un "dénigrement" ? Faut arrêter. Et puis les grandes généralités sur les peuples et leur mentalités faut arrêter aussi.

Donc toi tu peut être direct mais faut surtout pas qu'on donnent notre avis sur ce que tu propose, genre faut dire "ah oui génial c'est super tout ça" alors qu'on pensent que ça peut être amélioré ou que des choses ne vont pas forcément. Ah ouais c'est sûr c'est pas la même mentalité.

Aller salut !

ps: romain c'était évidement de l'ironie en réponse à la réaction puérile du dessus
ps2: je sais je ne respecte pas le pack de bonne conduite des modérateurs mais faut arrêter de délirer, si on peut même pas conseiller sans se faire taxer de tout et n'importe quoi 'tain !

Hors ligne

#16 12-12-2006 23:11:55

vin100
Habitué très actif

Re : PunOogle pour 1.2.14 tout pret 1.0

vin100 a écrit :

Je suis assez du même avis que Tommyl et c'est pour ça que je te posais la question. Beaucoup de personnes ont d'ores et déjà des mods installées. Tu peut pas dire à ces personnes "c'est la première mod que vous devez installer" ; ces personnes n'installeront donc pas ta mod. Généralement ceux qui installent des mods n'en installent pas qu'une. De plus le jours où une nouvelle version de PunBB sort, si jamais elle touche aux mêmes fichiers que ta mod alors cette dernière sera périmée. De plus pour quelqu'un qui ne s'y connais pas il va remplacer directement les fichiers sans chercher à comprendre, si il avait installé d'autres mods auparavant ça va être la misère, il va venir ici en criant pourquoi son forum marche plus. C'est pour cela que nous faisons des fichiers d'installation de mod en indiquant précisément ce qu'il faut modifier, pas pour faire suer les utilisateurs.

Il est où le dénigrement là dedans ? Je ne fait qu'expliquer ce qui est le mieux de faire. Je parle calmement, gentiment, j'explique le plus clairement possible.

Hors ligne

#17 12-12-2006 23:21:17

Tommyl
Régulier

Re : PunOogle pour 1.2.14 tout pret 1.0

Je ne donnais qu'un conseil de faire un fichier dans lequel tu listes les modifications que tu as faites afin de permettre aux gens de faire les modifications eux même sans utiliser tes fichiers. Je ne vois pas ce que j'ai dis de mal.

Maintenant, je trouve que ce thread part vraiment en sucette et je ne désire plus y participer.

Hors ligne

#18 12-12-2006 23:21:45

Dave
Membre

Re : PunOogle pour 1.2.14 tout pret 1.0

heum... quoi dire la dessus.

Je comprend pas pourquoi un admin s'enflamme ainsi. j'ai été courtois et limpide. Le zip explique tout dedans, avec un readme qui reprend tout ce qui a été dit a travers de multiples posts et reply... alors je vois pas pourquoi vous conseillez sans avoir vu auparavant ce qu'il contenais.

Ceci dit, si la majorité aiment mieux perdre des heures à faire les modifs, parcourir les posts, les retouches c'est leur choix. Le zip n'est n'y plus ni moins qu'une version fonctionnel et testé.

Je ne vous en veux pas, je ne suis pas en colère alors je comprend pas pourquoi certain le sont. Pour moi c'était que pour simplifier la vie au futur utilisateurs de punbb. C'est mon erreur.

a+:)

Hors ligne

#19 12-12-2006 23:22:40

Dave
Membre

Re : PunOogle pour 1.2.14 tout pret 1.0

Tommyl a écrit :

Je ne donnais qu'un conseil de faire un fichier dans lequel tu listes les modifications que tu as faites afin de permettre aux gens de faire les modifications eux même sans utiliser tes fichiers. Je ne vois pas ce que j'ai dis de mal.

Maintenant, je trouve que ce thread part vraiment en sucette et je ne désire plus y participer.

c'est exactement ce que le readme dans le zip dit... sad

Hors ligne

#20 12-12-2006 23:28:06

Dave
Membre

Re : PunOogle pour 1.2.14 tout pret 1.0

vin100 a écrit :

Il est où le dénigrement là dedans ? Je ne fait qu'expliquer ce qui est le mieux de faire. Je parle calmement, gentiment, j'explique le plus clairement possible.

En aucun cas j'ai dit que tu me dénigrais... Je sais pas pourquoi tu te sent concerné... Je suis autant surpris que toi dans cette histoire.

J'ai simplement dit que le zip contenais les fichiers deja modifiés avec un readme expliquand chaque modifs... Certain n'ont meme pas pris le temps de telechargé le zip pour y voir ce qu'il y avait dedans. C'est pas grave.

Hors ligne

#21 12-12-2006 23:36:12

vin100
Habitué très actif

Re : PunOogle pour 1.2.14 tout pret 1.0

je ne m'énerve pas parce que tu as fait des fichiers pré-modifié, comme Tommyl je n'avais pas téléchargé ta mod, je t'ai posé une question tu m'a répondu alors je t'ai donné mon avis et t'ai expliqué pourquoi j'avais cet avis, et je pense avoir également été courtois, je t'ai simplement expliqué pourquoi c'était bien de mettre des fichiers qui explique les étapes, c'était pour simplifier la vie future des utilisateurs qui ont déjà des mods

alors tu vois on voulaient tous les deux bien faire, mais tu aurait alors simplement dit "il y a ce fichier d'explications en plus des fichiers pre-modifiés" et voilà on en restaient là mais non tu trouve bon d'ajouter ton gros jugement de valeur complètement idiot sur notre façon de faire, sur notre mentalité, etc. et tu demande pourquoi je m'énerve ? parce que j'ai pas envie de supporter ce genre de réponse

Hors ligne

#22 12-12-2006 23:37:49

vin100
Habitué très actif

Re : PunOogle pour 1.2.14 tout pret 1.0

Dave a écrit :
vin100 a écrit :

Il est où le dénigrement là dedans ? Je ne fait qu'expliquer ce qui est le mieux de faire. Je parle calmement, gentiment, j'explique le plus clairement possible.

En aucun cas j'ai dit que tu me dénigrais... Je sais pas pourquoi tu te sent concerné... Je suis autant surpris que toi dans cette histoire.

relis toi mon grand, reprend le fil de la conversation, ça ne s'est pas passé exactement comme tu semble le croire

Dave a écrit :

c'est exactement ce que le readme dans le zip dit... sad

c'était ce qu'on te demandaient, suffisait simplement de nous le dire plutôt que t'offusquer parcequ'on expliquaient pourquoi ce genre de fichier est important

sur ce discussion close, une nouvelle version est disponible, inutile de continuer dans ce fouilli

Hors ligne

#23 13-12-2006 14:26:55

romain9441
Admin locker

Re : PunOogle pour 1.2.14 tout pret 1.0

vin100 a écrit :

ps: romain c'était évidement de l'ironie en réponse à la réaction puérile du dessus
ps2: je sais je ne respecte pas le pack de bonne conduite des modérateurs mais faut arrêter de délirer, si on peut même pas conseiller sans se faire taxer de tout et n'importe quoi 'tain !

J'avais vu ! tongue

C'est toi le chEf ! siffle


Avant de poser une question, avez-vous consulté la FAQ ou fait une recherche ?

Pas de support si pas d'adresse de forum !

Hors ligne

#24 13-12-2006 14:28:19

romain9441
Admin locker

Re : PunOogle pour 1.2.14 tout pret 1.0

Bon, je propose d'arréter ce H.S! tongue

C'est bon ? smile


Avant de poser une question, avez-vous consulté la FAQ ou fait une recherche ?

Pas de support si pas d'adresse de forum !

Hors ligne

#25 13-12-2006 15:00:14

vin100
Habitué très actif

Re : PunOogle pour 1.2.14 tout pret 1.0

en même temps c'est pas nous qui écrivons sur une discussion fermée tongue siffle

Hors ligne

Pied de page des forums