Archives FluxBB.fr

Les archives de FluxBB.fr

Recherche rapide

Vous n'êtes pas identifié(e).

Version 1.4.13 : [.tar.gz][.zip] (maj 20/10/2014)
Pack langue française pour 1.4.x : [.zip] (maj 06/01/2012)

Branche 1.5.x : fluxbb.org

Version 1.2.24 fr (entièrement en français) : [.zip] (maj 26/08/2011)
Pack langue française pour 1.2.x : [.zip] [.rar] (maj 15/10/2006)

Vous avez un problème ?
Avant de poser votre question sur les forums d'entraide nous vous invitons à consulter :

#1 02-12-2006 04:20:35

pinch
Membre

Compatibilité PunBB et PostgreSQL

...Suite à ce billet entre autres...

PostgreSQL est une alternative à MySQL concernant la base de donnée de PunBB.

- Il s'agit ici de ressencer les mods qui prennent en compte PostgreSQL en indiquant si cela fonctionne ou pas en ce qui me concerne ou ce qui vous concerne.
- Je suis en effet obligé à chaque fois de faire l'installation en manuelle.
- Je ne conseille pas l'installation avec PostgreSQL pour le moment à ceux qui ne veulent pas mettre les mains dans le cambouis.
- Merci de me prévenir de toute mise à jour ou autres mods defectueuses que je mettent à jour ce premier billet.

1/ prise en compte de PostgreSQL dans install_mod.php pour :
(mais ne fonctionne pas correctement)
- PunOnline

2/ pas de prise en compte de PostgreSQL dans install_mod.php pour :
- ChatBox
- Sexe de l'utilisateur

3/ ne fonctionne pas après bidouillage de ma part avec PostgreSQL pour :
- ChatBox

4/ fonctionne après bidouillage de ma part avec PostgreSQL :
- PunOnline
- Sexe de l'utilisateur

J'entends par bidouillage, l'intégration en manuelle de la base de données dans PostgreSQL (NB : l'accès PostgreSQL pour free est ici)

- Merci aux développeurs de Mods de faire le nécessaire pour rendre vos mods compatibles PostgreSQL en conséquence.
- Merci aux testeurs de Mods de faire un lien vers ce topic en réponse de tests infructueux pour PostgreSQL sur une Mods donnée.

Dernière modification par pinch (11-02-2007 00:19:20)

Hors ligne

#2 27-12-2006 20:46:01

vin100
Habitué très actif

Re : Compatibilité PunBB et PostgreSQL

j'avais pas vu ce post, c'est une bonne initiative, bien joué canon

Hors ligne

#3 28-12-2006 08:54:35

nico_somb
Habitué très actif

Re : Compatibilité PunBB et PostgreSQL

Je l'ai épinglé au passage smile

Hors ligne

#4 12-02-2007 00:25:21

PsychoKrameur
Nouveau Membre

Re : Compatibilité PunBB et PostgreSQL

J'avais commencé a installer sous postgres mais j'ai vite compris que vallais mieux faire sous mysql... :s

Hors ligne

#5 13-06-2007 10:02:08

pinch
Membre

Hors ligne

#6 13-06-2007 12:01:37

foxmask
Lugo

Re : Compatibilité PunBB et PostgreSQL

pgsql est supporté par punBB où est-il indiqué le contraire ?
http://punbb.org/about.php


http://www.foxmask.info
HaveFnuBB! le seul forum produit avec le framework PHP5 Jelix
(dé)pot de miel
Membre de la CoreTeam Jelix

Hors ligne

#8 13-06-2007 19:24:25

BertrandB
Membre

Re : Compatibilité PunBB et PostgreSQL

pinch a écrit :

c'est le développement des mods qui fait défaut niveau compatibilité

Donc il faut s'en passer wink ... lol

plus sérieusement ça dépend des mods et punbb fourni (dans include/dblayer) les outils pour être "relativement" indépendant du sgbd. Donc au pire il faut corriger le mod en question.

Hors ligne

#9 13-06-2007 20:27:36

foxmask
Lugo

Re : Compatibilité PunBB et PostgreSQL

oui c'est vrai qu'étant moins repandu chez les hebergeurs, postgresql déssert punBB :x


http://www.foxmask.info
HaveFnuBB! le seul forum produit avec le framework PHP5 Jelix
(dé)pot de miel
Membre de la CoreTeam Jelix

Hors ligne

#10 14-06-2007 09:07:21

pinch
Membre

Re : Compatibilité PunBB et PostgreSQL

Donc au pire il faut corriger le mod en question.

Je ne suis pas contre, c'est ce que je fais concernant l'un de mes forums, le problème c'est pour les non codeurs car peu de mods sont réellement compatibles.

Hors ligne

#11 14-06-2007 20:55:02

BertrandB
Membre

Re : Compatibilité PunBB et PostgreSQL

pinch a écrit :

le problème c'est pour les non codeurs car peu de mods sont réellement compatibles.

Donc ces mods sont d'infâmes bidouilles siffle
et des personnes censées ne devraient pas y toucher tongue

Bon c'est par où l'échafaud.

Hors ligne

#12 15-10-2007 22:09:55

paparsifal
Nouveau Membre

Re : Compatibilité PunBB et PostgreSQL

La version française de PunBB provoque (en tous cas chez moi) une erreur d'encodage lors de l'installation sur un serveur free avec postgresql.
La base de donnée est en UTF8 alors que les caractère accentués dans le fichier d'install son en encodage windows autrement dit : LATIN1 dans postgresql.
Pour que cela fonctionne j'ai rajouter une petite ligne dans le fichier d'install :

            if (version_compare(PHP_VERSION, '4.3.0', '<'))
                error('Vous utilisez la version '.PHP_VERSION.'de PHP. PunBB nécéssite au minimum PHP 4.3.0 pour fonctionner correctement avec PostgreSQL. Vous devez mettre à jour votre installation de PHP ou utiliser une base de données différente pour continuer.');
                $db->query("SET CLIENT_ENCODING TO 'LATIN1';"); //patch pour eviter les problèmes d'encodage
            break;

et le tour est joué...

... et bien non... les problèmes n'étais pas fini, impossible de créer des catégories avec accent, etc...
J'ai donc à nouveau plongé dans le code et trouvé l'endroit à modifier :
dans include/dblayer/pgsql.php

        if (!$this->link_id)
            error('Unable to connect to PostgreSQL server', __FILE__, __LINE__);
        else
            @pg_send_query($this->link_id, "SET CLIENT_ENCODING TO 'LATIN1';"); // patch pour UTF8
            return $this->link_id;
    }

et voila !

Dernière modification par paparsifal (15-10-2007 22:19:42)

Hors ligne

#13 15-10-2007 22:16:29

Pandark
Guide

Re : Compatibilité PunBB et PostgreSQL

Ça n'est pas forcément lié au type de base de donnée, mais peut-être aux réglages de celle-ci (à mon avis, le même type de bug peut se produire avec mysql...)
Mais le patch est quand même une bonne idée à mon avis. smile


=>  Plugins | Modifications | Liens utiles   <=
                .._ -Pandark- _..
                Serial Dreamer

Hors ligne

Pied de page des forums