Archives FluxBB.fr

Les archives de FluxBB.fr

Recherche rapide

Vous n'êtes pas identifié(e).

Version 1.4.13 : [.tar.gz][.zip] (maj 20/10/2014)
Pack langue française pour 1.4.x : [.zip] (maj 06/01/2012)

Branche 1.5.x : fluxbb.org

Version 1.2.24 fr (entièrement en français) : [.zip] (maj 26/08/2011)
Pack langue française pour 1.2.x : [.zip] [.rar] (maj 15/10/2006)

Vous avez un problème ?
Avant de poser votre question sur les forums d'entraide nous vous invitons à consulter :

#51 30-09-2006 13:35:46

zillah
Membre

Re : Easy Poll+ 2.0

Salut,

Est-il possible d'avoir plus de 10 choix dans la question à choix multiple????


Nous vivons peut-être tous sur la même planète, mais nous ne vivons pas tous dans le même monde !!

Hors ligne

#52 30-09-2006 13:43:44

jgui
Membre

Re : Easy Poll+ 2.0

zillah a écrit :

Salut,

Est-il possible d'avoir plus de 10 choix dans la question à choix multiple????

je suis juste utilisateur...mais dans le plug-in on peut mettre plus de 10 et qd on saisie ça à l'air de marcher

Hors ligne

#54 04-10-2006 16:07:25

romain9441
Admin locker

Re : Easy Poll+ 2.0

Félicitations tongue

Au faite mon pseudo sur PunRes c'est Romain tongue


Avant de poser une question, avez-vous consulté la FAQ ou fait une recherche ?

Pas de support si pas d'adresse de forum !

Hors ligne

#55 04-10-2006 16:08:12

romain9441
Admin locker

Re : Easy Poll+ 2.0

Et tu n'as pas mis les améliorations ?

Désolé pour le double post ...

Dernière modification par romain9441 (04-10-2006 16:14:35)


Avant de poser une question, avez-vous consulté la FAQ ou fait une recherche ?

Pas de support si pas d'adresse de forum !

Hors ligne

#56 04-10-2006 17:08:27

BN
Habitué

Re : Easy Poll+ 2.0

Au faite mon pseudo sur PunRes c'est Romain

J'avais cru comprendre^^ (bah c'est simple, ton pseudo c'est Romain sur tous les forums où je te vois tongue)

Non, je n'ai pas mis les améliorations. (j'aurais certainement pas le temps de faire le truc d'édition avant les vacances (3-4 semaines quoi) c'est... légérement compliqué à faire...)

Hors ligne

#57 05-10-2006 19:10:59

romain9441
Admin locker

Re : Easy Poll+ 2.0

BN a écrit :

Au faite mon pseudo sur PunRes c'est Romain

J'avais cru comprendre^^ (bah c'est simple, ton pseudo c'est Romain sur tous les forums où je te vois tongue)

Sauf ici, ne me demande pas pourquoi hmm


Avant de poser une question, avez-vous consulté la FAQ ou fait une recherche ?

Pas de support si pas d'adresse de forum !

Hors ligne

#58 08-10-2006 18:27:34

izguit
Nouveau Membre

Re : Easy Poll+ 2.0

salut tout le monde,
je suis un petit nouveau avec PunBB et j'ai envie d'y apporter pas mal de modifs, mais quand je télécharge des mods (celui-çi comme d'autres) et que j'ouvre le readme... hmm une bonne cinquantaine de modifs à faire dans les fichiers? Est-ce obligatoire? Un script n'existe-t-il pas? Ca me rebute un peu de tout faire à la main smile
Très bon boulot sinon.

a+ izguit

Hors ligne

#59 08-10-2006 18:33:34

romain9441
Admin locker

Re : Easy Poll+ 2.0

Tu dois tous faire à la main, c'est la seule et unique solution wink


Avant de poser une question, avez-vous consulté la FAQ ou fait une recherche ?

Pas de support si pas d'adresse de forum !

Hors ligne

#60 08-10-2006 18:34:23

jgui
Membre

Re : Easy Poll+ 2.0

izguit a écrit :

salut tout le monde,
je suis un petit nouveau avec PunBB et j'ai envie d'y apporter pas mal de modifs, mais quand je télécharge des mods (celui-çi comme d'autres) et que j'ouvre le readme... hmm une bonne cinquantaine de modifs à faire dans les fichiers? Est-ce obligatoire? Un script n'existe-t-il pas? Ca me rebute un peu de tout faire à la main smile
Très bon boulot sinon.

a+ izguit

c'est galère mais il y a pas le choix je crois...moi j'ai tout fait...ligne par ligne ;-)

Hors ligne

#61 08-10-2006 19:03:28

izguit
Nouveau Membre

Re : Easy Poll+ 2.0

ok smile merci

Hors ligne

#62 08-11-2006 20:37:19

romain9441
Admin locker

Re : Easy Poll+ 2.0

Tu sais chercher ? siffle

Y a deux Lisez-Moi, et c'est correctement expliqué que si tu n'as pas Easy Poll 1.1.3 d'installé sur ton forum d'utiliser l'autre Lisez-Moi !


Avant de poser une question, avez-vous consulté la FAQ ou fait une recherche ?

Pas de support si pas d'adresse de forum !

Hors ligne

#63 10-11-2006 18:27:36

BN
Habitué

Re : Easy Poll+ 2.0

Soit pas triste Tristou ! ça arrive à tout le monde wink
(la fatigue...)

Cette version d'Easy Poll+ est tout à fait stable. (quoi qu'en dise les anglais) Elle pourrait être encore amélioré, mais sinon, elle tient tout à fait la route smile

Hors ligne

#64 20-11-2006 01:15:07

Electrospirit
Nouveau Membre

Re : Easy Poll+ 2.0

Salut à tous, voici mon problème sur lequel je sèche depuis plusieurs heures ( voir complément info http://www.punbb.fr/forums/viewtopic.ph … 377#p29377 ) :

Mon problème se situe désormais dans administration/forums/Modifier les forums/ modifier

Suite à l'installation de cette mod, chaque fois que je veux modifier une permission, je valide et il ne prend pas en compte les modifs. Le tout sans message d'erreur ni rien. En ce qui concerne les sondages pas de problèmes. Seule la colonne Lancer des discussions ( apparaissant et bizarrement en rose ) pose ce problème.

Des idées ?

sanstitreby1.png

Clic droit Afficher l'image

Dernière modification par Electrospirit (20-11-2006 01:20:07)

Hors ligne

#65 20-11-2006 19:35:10

romain9441
Admin locker

Re : Easy Poll+ 2.0

Les permissions n'ont pas été créés dans la BDD.


Avant de poser une question, avez-vous consulté la FAQ ou fait une recherche ?

Pas de support si pas d'adresse de forum !

Hors ligne

#66 20-11-2006 20:09:23

BN
Habitué

Re : Easy Poll+ 2.0

+1

Pour la coloration rose, j'avais eu ce problème aussi. C'était pas bien grave, donc je n'avais pas vraiment cherché, mais toujours est-il que je n'avais pas trouvé de sources d'erreurs. A voir si d'autres ont le même problème.

En tout cas, cette mod à l'air de bien fonctionner vu qu'il y a eu environ 390 téléchargements sur punbb.fr et presque autant sur Punres ! Que les derniers sceptiques soient donc rassuré^^ Et que d'autres motivés créent une nouvelle version avec toutes les modifs proposés siffle

Hors ligne

#67 20-11-2006 20:12:51

Electrospirit
Nouveau Membre

Re : Easy Poll+ 2.0

Bonjour,

romain9441 a écrit :

Les permissions n'ont pas été créés dans la BDD.

Et donc quelle solution faut-il appliquer ? Merci à vous deux.

Dernière modification par Electrospirit (20-11-2006 20:13:08)

Hors ligne

#68 20-11-2006 20:28:48

BN
Habitué

Re : Easy Poll+ 2.0

As-tu bien lancé le fichier 'instal_mod_fr.php ? (ou un truc dans le genre^^) Ou fais les modifications "à la mains", pour que ce nouveau type de permissions puissent être effectué ?

Hors ligne

#69 20-11-2006 22:04:41

Electrospirit
Nouveau Membre

Re : Easy Poll+ 2.0

Oui, j'ai tout installé à la main, install_mod compris. J'ai même refait les modifications sur admin_forums une seconde fois en partant du fichier original punbb. Y a moyen d'agir directement dans la bdd via phpmyadmin pour rajouter ces permissions ?

Hors ligne

#70 21-11-2006 13:59:58

romain9441
Admin locker

Re : Easy Poll+ 2.0

Oui, il faut ajouter les requètes de l'install_mod.php manuellement, j'ai remarqué que sur ta version BN', il manquait des requètes dans les install_mod.php. hmm

Tu vérifis ?


Avant de poser une question, avez-vous consulté la FAQ ou fait une recherche ?

Pas de support si pas d'adresse de forum !

Hors ligne

#71 24-11-2006 13:08:40

Electrospirit
Nouveau Membre

Re : Easy Poll+ 2.0

romain9441 a écrit :

Oui, il faut ajouter les requètes de l'install_mod.php manuellement, j'ai remarqué que sur ta version BN', il manquait des requètes dans les install_mod.php. hmm

Tu vérifis ?

Bah, je ne peux pas vérifier, je ne suis pas spécialiste des requêtes. Donc, si j'ai bien compris le mod comporte des bugs ou est mal finalisé au niveau de l'install_mod ... ( désolé si je n'emploie pas les bons termes ).Ce qui explique que j'ai eu ce problème...

Y a t-il une solution provisoire ?

Hors ligne

#72 24-11-2006 20:55:08

romain9441
Admin locker

Re : Easy Poll+ 2.0

Je parlais à BN ! big_smile

Electrospirit a écrit :

ou est mal finalisé au niveau de l'install_mod

plus_un


Avant de poser une question, avez-vous consulté la FAQ ou fait une recherche ?

Pas de support si pas d'adresse de forum !

Hors ligne

#73 25-11-2006 14:59:08

BN
Habitué

Re : Easy Poll+ 2.0

ou est mal finalisé au niveau de l'install_mod

Quoi ? **Strange attitude** huh

Voilà ce que créé normalement l'install_mod.php (et update) pour que les permissions puissent être géré :

$db->query("ALTER TABLE ".$db->prefix."forum_perms ADD `post_polls` TINYINT(1) DEFAULT '1' NOT NULL") or error('Impossible d\'ajouter les champs nécessaires à la table', __FILE__, __LINE__, $db->error());

Il faudrait aussi "normalement" créé une entrée "g_post_polls" dans la base _groupes, mais pour une raison inconnue (de moi en tout cas^^) cette entrée existe déjà à l'origine sur PunBB ! Enfin sur la version 1.2.12 en tout cas tongue

Moralité Electrospirit : il ne te reste plus qu'à vérifier que ces 2 entrées existent bien dans ta BDD ! Si ce n'est pas le cas, bah tu sais ce qui te reste à faire ! (et si l'entrée  "g_post_polls" n'existe pas, éh bien dis-le histoire que je puisse créé une nouvelle version tongue)

Hors ligne

#74 26-11-2006 00:48:37

pinch
Membre

Re : Easy Poll+ 2.0

Bonsoir,
Alors voilà j'ai essayé d'installer Easy Poll à plusieurs reprises.
Ma difficulté c'est qu'il doit fonctionner avec postgreSQL.
Pour une fois, c'est pris en compte dans la création d'une mod, ça c'est bien.
le problème c'est que ça ne marche pas chez moi.
erreur1.jpg

Sans soucis, je crée alors  la table en manuel et modifie les deux autres.
Plus ajouts dans la table _config
erreur2.jpg

Le problème persiste à la création d'un sondage.
ça bloc sur la création dans la table _pools.

if ($ptype != 0) 
                    $db->query('INSERT INTO ' . $db->prefix . 'polls (pollid, options, ptype) VALUES(' . $new_tid . ', \'' . $db->escape(serialize($option)) . '\', ' . $ptype . ')') or error('Unable to create poll', __FILE__, __LINE__, $db->error());
            }

Ne serait-ce pas l'id en interger que pose problème ?

PS: je suis chez free

Ensuite, concernant PostgreSQL lorsque je crée un sondage j'ai l'erreur suivante :
[c]Unable to create poll.[/c]

qui correspond à :

if(isset($ptype)) // Si c'est un sondage
            {
                if ($ptype == 3) 
                    $db->query('INSERT INTO ' . $db->prefix . 'topics (poster, subject, posted, last_post, last_poster, forum_id, question, yes, no) VALUES(\'' . $db->escape($username) . '\', \'' . $db->escape($subject) . '\', ' . $now . ', ' . $now . ', \'' . $db->escape($username) . '\', ' . $fid . ', \'' . $db->escape($question) . '\', \'' . $db->escape($yesval) . '\', \'' . $db->escape($noval) . '\')') or error('Unable to create topic', __FILE__, __LINE__, $db->error());
                else
                    $db->query('INSERT INTO ' . $db->prefix . 'topics (poster, subject, posted, last_post, last_poster, forum_id, question) VALUES(\'' . $db->escape($username) . '\', \'' . $db->escape($subject) . '\', ' . $now . ', ' . $now . ', \'' . $db->escape($username) . '\', ' . $fid . ', \'' . $db->escape($question) . '\')') or error('Unable to create topic', __FILE__, __LINE__, $db->error());

                $new_tid = $db->insert_id();
                if ($ptype != 0) 
                    $db->query('INSERT INTO ' . $db->prefix . 'polls (pollid, options, ptype) VALUES(' . $new_tid . ', \'' . $db->escape(serialize($option)) . '\', ' . $ptype . ')') or error('Unable to create poll', __FILE__, __LINE__, $db->error());
            }

Voyez-vous l'erreur ?

Dernière modification par pinch (02-12-2006 22:22:09)

Hors ligne

#75 26-11-2006 03:02:55

Illusion
Habitué

Re : Easy Poll+ 2.0

Non, c'est juste une petite erreur dans le code. Tu as mis \'' au lieu de '\'. Voila le code correct.

if ($ptype != 0) 
                    $db->query('INSERT INTO ' . $db->prefix . 'polls (pollid, options, ptype) VALUES(' . $new_tid . ', '\' . $db->escape(serialize($option)) . '\', ' . $ptype . ')') or error('Unable to create poll', __FILE__, __LINE__, $db->error());
            }

Dernière modification par Illusion (26-11-2006 03:03:54)


*-- Illusion --*
PoesieLand, la poésie sommeille en vous !

Hors ligne

Pied de page des forums